CF 1187B-Letters Shop-二分查找

The letters shop showcase is a string s, consisting of n lowercase Latin letters. As the name tells, letters are sold in the shop.

Letters are sold one by one from the leftmost to the rightmost. Any customer can only buy some prefix of letters from the string s

There are m friends, the i-th of them is named ti. Each of them is planning to estimate the following value: how many letters (the length of the shortest prefix) would s/he need to buy if s/he wanted to construct her/his name of bought letters. The name can be constructed if each letter is presented in the equal or greater amount.

For example, for s=“arrayhead” and ti=“arya” 5 letters have to be bought (“arrayhead”).
For example, for s=“arrayhead” and ti=“harry” 6 letters have to be bought (“arrayhead”).
For example, for s=“arrayhead” and ti=“ray” 5 letters have to be bought (“arrayhead”).
For example, for s=“arrayhead” and ti=“r” 2 letters have to be bought (“arrayhead”).
For example, for s=“arrayhead” and ti=“areahydra” all 9 letters have to be bought (“arrayhead”).

It is guaranteed that every friend can construct her/his name using the letters from the string s.

Note that the values for friends are independent, friends are only estimating them but not actually buying the letters.

Input

The first line contains one integer n (1≤n≤2⋅105) — the length of showcase string s.
The second line contains string s, consisting of exactly n lowercase Latin letters.
The third line contains one integer m(1≤m≤5⋅104) — the number of friends.
The i-th of the next m lines contains ti (1≤|ti|≤2⋅105) — the name of the i-th friend.
It is guaranteed that ∑i=1m|ti|≤2⋅105

Output

For each friend print the length of the shortest prefix of letters from s s/he would need to buy to be able to construct her/his name of them. The name can be constructed if each letter is presented in the equal or greater amount.

It is guaranteed that every friend can construct her/his name using the letters from the string s.

Sample Input

9
arrayhead
5
arya
harry
ray
r
areahydra

Sample Output

5
6
5
2
9

题目大意:

给定一个字符串s,含有n个小写字母。
接下来是m次独立的询问,每次询问:
给定一个字符串t,问至少使用s的前几个字符可以构造出t。字符可以有多余,但必须够用

核心思想:

a[i][j]表示s的前i个字符中含有字母’a’+j的个数。数组a是升序的。
b[j]表示t中含有字母’a’+j的个数
每一次查询,二分查找满足数组b的最小的i值。

代码如下:

#include<cstdio>
#include<iostream>
#include<cstring>
using namespace std;
typedef long long ll;
const int N=2e5+20;
char s[N],t[N];
int a[N][28],b[28];
//二分查找 
int erfen(int n)
{
	int l=0,r=n-1,flag;
	while(r-l>1)
	{
		int mid=(l+r)>>1;
		flag=0;
		for(int i=0; i<26; i++)
			if(a[mid][i]<b[i])
			{
				flag=1;
				break;
			}
		if(flag)
			l=mid;
		else
			r=mid;
	}
	flag=0;
	for(int i=0; i<26; i++)
		if(a[l][i]<b[i])
		{
			flag=1;
			break;
		}
	if(!flag)
		return l;
	return r;
}
int main()
{
	int n,m;
	scanf("%d",&n);
	scanf("%s",s);
	//得到数组a 
	a[0][s[0]-'a']=1;
	for(int i=1; i<n; i++)
	{
		for(int j=0; j<26; j++)
			a[i][j]=a[i-1][j];
		a[i][s[i]-'a']++;
	}
	//m次查询并输出 
	scanf("%d",&m);
	for(int i=0; i<m; i++)
	{
		for(int j=0; j<26; j++)
			b[j]=0;
		scanf("%s",t);
		int len=strlen(t);
		for(int j=0; j<len; j++)
			b[t[j]-'a']++;
		printf("%d\n",erfen(n)+1);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/Nothing_but_Fight/article/details/98098910