USACO Hide and Seek

洛谷 P2951 [USACO09OPEN]捉迷藏Hide and Seek

洛谷传送门

JDOJ 2641: USACO 2009 Open Silver 1.Hide and Seek

JDOJ传送门

题目描述

Bessie is playing hide and seek (a game in which a number of players hide and a single player (the seeker) attempts to find them after which various penalties and rewards are assessed; much fun usually ensues).

She is trying to figure out in which of N (2 <= N <= 20,000) barns conveniently numbered 1..N she should hide. She knows that FJ (the seeker) starts out in barn 1. All the barns are connected by M (1 <= M <= 50,000) bidirectional paths with endpoints A_i and B_i (1 <= A_i <= N; 1 <= B_i <= N; A_i != B_i); it is possible to reach any barn from any other through the paths.

Bessie decides that it will be safest to hide in the barn that has the greatest distance from barn 1 (the distance between two barns is the smallest number of paths that one must traverse to get from one to the other). Help Bessie figure out the best barn in which to hide.

奶牛贝西和农夫约翰(FJ)玩捉迷藏,现在有N个谷仓,FJ开始在第一个谷仓,贝西为了不让FJ找到她,当然要藏在距离第一个谷仓最远的那个谷仓了。现在告诉你N个谷仓,和M个两两谷仓间的“无向边”。每两个仓谷间当然会有最短路径,现在要求距离第一个谷仓(FJ那里)最远的谷仓是哪个(所谓最远就是距离第一个谷仓最大的最短路径)?如有多个则输出编号最小的。以及求这最远距离是多少,和有几个这样的谷仓距离第一个谷仓那么远。

输入格式

* Line 1: Two space-separated integers: N and M

* Lines 2..M+1: Line i+1 contains the endpoints for path i: A_i and B_i

第一行:两个整数N,M;

第2-M+1行:每行两个整数,表示端点A_i 和 B_i 间有一条无向边。

输出格式

* Line 1: On a single line, print three space-separated integers: the index of the barn farthest from barn 1 (if there are multiple such barns, print the smallest such index), the smallest number of paths needed to reach this barn from barn 1, and the number of barns with this number of paths.

仅一行,三个整数,两两中间空格隔开。表示:距离第一个谷仓最远的谷仓编号(如有多个则输出编号最小的。),以及最远的距离,和有几个谷仓距离第一个谷仓那么远。

Sample Input

6 7 3 6 4 3 3 2 1 3 1 2 2 4 5 2

Sample Output

4 2 3

SPFA的一道模板题,怎么说呢?应该是模板题加深了一点点。

首先我们理解好这题的三个问:

第一问,最长路谷仓编号。这里的最长路是最大的最短路。

第二问,最长路是多少。

第三问,有几条最长路。

然后就没有然后了。

先跑SPFA得出一个f数组存储从源点1开始到i点的最短路。

然后从头枚举,碰到更长的最短路就更新+记录,记录编号(ans)和总数(cnt),就可以轻松AC啦!

上代码:

#include<cstdio>
#include<queue>
#include<cstring>
using namespace std;
int n,m,lst,ans,cnt;
int tot,to[100001],nxt[100001],head[20001];
void add(int x,int y)
{
    to[++tot]=y;
    nxt[tot]=head[x];
    head[x]=tot;
}
int f[20001],v[20001];
void spfa()
{
    memset(f,0x3f,sizeof(f));
    memset(v,0,sizeof(v));
    queue<int> q;
    q.push(1);
    f[1]=0;
    while(!q.empty())
    {
        int x=q.front();
        q.pop();
        v[x]=0;
        for(int i=head[x];i;i=nxt[i])
        {
            int y=to[i];
            if(f[y]>f[x]+1)
            {
                f[y]=f[x]+1;
                if(v[y]==0)
                    q.push(y),v[y]=1;
            }
        }
    }
}
int main()
{
    scanf("%d%d",&n,&m);
    for(int i=1;i<=m;i++)
    {
        int x,y;
        scanf("%d%d",&x,&y);
        add(x,y);
        add(y,x);
    }
    spfa();
    for(int i=1;i<=n;i++)
    {
        if(f[i]>lst)
        {
            lst=f[i];
            ans=i;
            cnt=1;
        }
        else if(f[i]==lst)
            cnt++;
    }
    printf("%d %d %d",ans,lst,cnt);
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/fusiwei/p/11263808.html