POJ - 1976 A Mini Locomotive DP 记忆化搜索

A train has a locomotive that pulls the train with its many passenger coaches. If the locomotive breaks down, there is no way to pull the train. Therefore, the office of railroads decided to distribute three mini locomotives to each station. A mini locomotive can pull only a few passenger coaches. If a locomotive breaks down, three mini locomotives cannot pull all passenger coaches. So, the office of railroads made a decision as follows: 

1. Set the number of maximum passenger coaches a mini locomotive can pull, and a mini locomotive will not pull over the number. The number is same for all three locomotives. 
2. With three mini locomotives, let them transport the maximum number of passengers to destination. The office already knew the number of passengers in each passenger coach, and no passengers are allowed to move between coaches. 
3. Each mini locomotive pulls consecutive passenger coaches. Right after the locomotive, passenger coaches have numbers starting from 1. 

For example, assume there are 7 passenger coaches, and one mini locomotive can pull a maximum of 2 passenger coaches. The number of passengers in the passenger coaches, in order from 1 to 7, is 35, 40, 50, 10, 30, 45, and 60. 

If three mini locomotives pull passenger coaches 1-2, 3-4, and 6-7, they can transport 240 passengers. In this example, three mini locomotives cannot transport more than 240 passengers. 

Given the number of passenger coaches, the number of passengers in each passenger coach, and the maximum number of passenger coaches which can be pulled by a mini locomotive, write a program to find the maximum number of passengers which can be transported by the three mini locomotives. 
Input
The first line of the input contains a single integer t (1 <= t <= 11), the number of test cases, followed by the input data for each test case. The input for each test case will be as follows: 
The first line of the input file contains the number of passenger coaches, which will not exceed 50,000. The second line contains a list of space separated integers giving the number of passengers in each coach, such that the i  th number of in this line is the number of passengers in coach i. No coach holds more than 100 passengers. The third line contains the maximum number of passenger coaches which can be pulled by a single mini locomotive. This number will not exceed 1/3 of the number of passenger coaches. 
Output
There should be one line per test case, containing the maximum number of passengers which can be transported by the three mini locomotives.
Sample Input
1
7
35 40 50 10 30 45 60
2
Sample Output

240

题意:有三辆机车,n辆客车,一辆机车可以拉k辆客车,而且拉的客车必须连续,求能拉的乘客的最大数量;

状态转移方程:dp[i][j]=max(dp[i][j-1],dp[i-1][j-k]+num[j]

#include<iostream>
#include<cstdio>
#include<map>
#include<string>
#include<cstring>
using namespace std;
const int len=5e4+5;
#define ll long long
int arr[len],n;
int k,num[len];
int dp[3][len];//dp[i][j]为用i辆机车拉前j辆客车所能容纳的最大乘客 
int dfs(int i,int j)
{
	if(i<0||j<0)return 0;//边界 
	if(dp[i][j]!=-1)return dp[i][j];
	dp[i][j]=max(dfs(i,j-1),dfs(i-1,j-k)+num[j]);
	//dp[i][j]可以由二个状态转移过来;1:用i辆机车,拉前j-1辆客车,2:用i-1辆机车拉j-k辆客车+(j-k+1到j)的乘客数量 
	return dp[i][j];
}
int main()
{
	int t;
	cin>>t;
	while(t--)
	{
		memset(dp,-1,sizeof(dp));
		memset(num,0,sizeof(num));
		scanf("%d",&n);
		for(int i=0;i<n;++i)
		{
			scanf("%d",arr+i);
		}
		scanf("%d",&k);
		for(int i=k-1;i<n;++i)
		{
			for(int j=i-k+1;j<=i;++j)
			{
				num[i]+=arr[j];
			}
		}
		printf("%d\n",dfs(2,n-1));
	} 
} 

猜你喜欢

转载自blog.csdn.net/hutwuguangrong/article/details/80231718