浇地Watering the Fields

版权声明:代码原创,如需转载,请发邮箱至[email protected][email protected],或qq3145743347. https://blog.csdn.net/ebirth/article/details/91347158

题目描述

Due to a lack of rain, Farmer John wants to build an irrigation system to

send water between his N fields (1 <= N <= 2000).

Each field i is described by a distinct point (xi, yi) in the 2D plane,

with 0 <= xi, yi <= 1000. The cost of building a water pipe between two

fields i and j is equal to the squared Euclidean distance between them:

(xi - xj)^2 + (yi - yj)^2

FJ would like to build a minimum-cost system of pipes so that all of his

fields are linked together – so that water in any field can follow a

sequence of pipes to reach any other field.

Unfortunately, the contractor who is helping FJ install his irrigation

system refuses to install any pipe unless its cost (squared Euclidean

length) is at least C (1 <= C <= 1,000,000).

Please help FJ compute the minimum amount he will need pay to connect all

his fields with a network of pipes.

农民约翰想建立一个灌溉系统,给他的NNN (1 <= NNN <= 2000)块田送水。农田在一个二维平面上,第i块农田坐标为(xix_ixi​ , yiy_iyi​ )(0 <= xix_ixi​ , yiy_iyi​ <= 1000),在农田iii 和农田jjj 自己铺设水管的费用是这两块农田的欧几里得距离的平方(xi−xj)2+(yi−yj)2(x_i - x_j)^2 + (y_i - y_j)^2(xi​−xj​)2+(yi​−yj​)2 。

农民约翰希望所有的农田之间都能通水,而且希望花费最少的钱。但是安装工人拒绝安装费用小于C的水管(1 <= CCC <= 1,000,000)。

请帮助农民约翰建立一个花费最小的灌溉网络,如果无法建立请输出-1。
输入输出格式
输入格式:

  • Line 1: The integers N and C.

  • Lines 2…1+N: Line i+1 contains the integers xi and yi.

输出格式:

  • Line 1: The minimum cost of a network of pipes connecting the

fields, or -1 if no such network can be built.

输入输出样例
输入样例#1: 复制

3 11
0 2
5 0
4 3

输出样例#1: 复制

46

说明

INPUT DETAILS:

There are 3 fields, at locations (0,2), (5,0), and (4,3). The contractor

will only install pipes of cost at least 11.

OUTPUT DETAILS:

FJ cannot build a pipe between the fields at (4,3) and (5,0), since its

cost would be only 10. He therefore builds a pipe between (0,2) and (5,0)

at cost 29, and a pipe between (0,2) and (4,3) at cost 17.

Source: USACO 2014 March Contest, Silver

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <vector>
#include <queue>
#include <cctype>
#define ri register int 
#define ll long long 
using namespace std;
const int maxn=2005;
const int inf=192681792;
struct Edge{
int u,v,dis;
bool operator <(const Edge& b)const{
    return dis<b.dis;
}
}edge[19260817];//边数不要设小了 
int n,c,tot=0;
int px[maxn],py[maxn];
int fa[maxn];
int get(int x){
if(fa[x]!=x)fa[x]=get(fa[x]);
return fa[x];
}
inline void kruskal(){
int u,v,dis;
int cnt=0,ans=0;
for(ri i=1;i<=n;i++){
    fa[i]=i;
}
for(ri i=1;i<=tot;i++){
    u=edge[i].u,v=edge[i].v;
    u=get(u),v=get(v);
    if(u!=v){
        fa[u]=v;
        ans+=edge[i].dis;
        cnt++;
    }
    if(cnt==n-1)break;
}
if(cnt==n-1)printf("%d",ans);
else puts("-1");
return ;
}
int main(){
scanf("%d %d",&n,&c);
for(ri i=1;i<=n;i++){
    scanf("%d %d",&px[i],&py[i]);
    for(ri j=1;j<i;j++){
        int d=(px[i]-px[j])*(px[i]-px[j])+(py[i]-py[j])*(py[i]-py[j]);
        if(d>=c){
            edge[++tot].u=i,edge[tot].v=j,edge[tot].dis=d;
        }
    }
}
sort(edge+1,edge+1+tot);
kruskal();
return 0;
}

猜你喜欢

转载自blog.csdn.net/ebirth/article/details/91347158
今日推荐