PTA 1004-成绩排名 c和python编写

1004题目:

1004 成绩排名 (20 分)

读入 n(>0)名学生的姓名、学号、成绩,分别输出成绩最高和成绩最低学生的姓名和学号。

输入格式:

每个测试输入包含 1 个测试用例,格式为

第 1 行:正整数 n
第 2 行:第 1 个学生的姓名 学号 成绩
第 3 行:第 2 个学生的姓名 学号 成绩
… … …
第 n+1 行:第 n 个学生的姓名 学号 成绩
其中姓名和学号均为不超过 10 个字符的字符串,成绩为 0 到 100 之间的一个整数,这里保证在一组测试用例中没有两个学生的成绩是相同的。

输出格式:

对每个测试用例输出 2 行,第 1 行是成绩最高学生的姓名和学号,第 2 行是成绩最低学生的姓名和学号,字符串间有 1 空格。

输入样例:

3
Joe Math990112 89
Mike CS991301 100
Mary EE990830 95

输出样例:

Mike CS991301
Joe Math990112

C语言代码:

#include <stdio.h>
#include <stdlib.h>

typedef struct student{
    char name[11];
    char id[11];
    int score;
    }Stu;

int main()
{
    int n;
    scanf("%d",&n);
    Stu stu[n];
    int max,min;
    int maxNum,minNum;
    for(int i=0;i<n;i++)
    {
        scanf("%s %s %d",stu[i].name,stu[i].id,&stu[i].score);
        if(i==0){
            max=stu[0].score;
            min=stu[0].score;
            maxNum=0;
            minNum=0;
        }
        if(stu[i].score>max){
            max=stu[i].score;
            maxNum=i;
        }
        if(stu[i].score<min){
            min=stu[i].score;
            minNum=i;
        }

    }
    printf("%s %s\n",stu[maxNum].name,stu[maxNum].id);
    printf("%s %s\n",stu[minNum].name,stu[minNum].id);

    return 0;
}

python代码:

max = 0
min = 101
n = input()
for i in range(int(n)):
    s = input()
    str = s.split()
    if int(str[2]) > max:
        max = int(str[2])
        max_mesg = str[0]+" "+str[1]
    if int(str[2]) < min:
        min = int(str[2])
        min_mesg = str[0]+" "+str[1]
print(max_mesg)
print(min_mesg)

猜你喜欢

转载自blog.csdn.net/qq_32188669/article/details/92844472