MPI Maelstrom (Dijstra+atoi函数转换整数)

BIT has recently taken delivery of their new supercomputer, a 32 processor Apollo Odyssey distributed shared memory machine with a hierarchical communication subsystem. Valentine McKee's research advisor, Jack Swigert, has asked her to benchmark the new system. 
``Since the Apollo is a distributed shared memory machine, memory access and communication times are not uniform,'' Valentine told Swigert. ``Communication is fast between processors that share the same memory subsystem, but it is slower between processors that are not on the same subsystem. Communication between the Apollo and machines in our lab is slower yet.'' 

``How is Apollo's port of the Message Passing Interface (MPI) working out?'' Swigert asked. 

``Not so well,'' Valentine replied. ``To do a broadcast of a message from one processor to all the other n-1 processors, they just do a sequence of n-1 sends. That really serializes things and kills the performance.'' 

``Is there anything you can do to fix that?'' 

``Yes,'' smiled Valentine. ``There is. Once the first processor has sent the message to another, those two can then send messages to two other hosts at the same time. Then there will be four hosts that can send, and so on.'' 

``Ah, so you can do the broadcast as a binary tree!'' 

``Not really a binary tree -- there are some particular features of our network that we should exploit. The interface cards we have allow each processor to simultaneously send messages to any number of the other processors connected to it. However, the messages don't necessarily arrive at the destinations at the same time -- there is a communication cost involved. In general, we need to take into account the communication costs for each link in our network topologies and plan accordingly to minimize the total time required to do a broadcast.''

Input

The input will describe the topology of a network connecting n processors. The first line of the input will be n, the number of processors, such that 1 <= n <= 100. 

The rest of the input defines an adjacency matrix, A. The adjacency matrix is square and of size n x n. Each of its entries will be either an integer or the character x. The value of A(i,j) indicates the expense of sending a message directly from node i to node j. A value of x for A(i,j) indicates that a message cannot be sent directly from node i to node j. 

Note that for a node to send a message to itself does not require network communication, so A(i,i) = 0 for 1 <= i <= n. Also, you may assume that the network is undirected (messages can go in either direction with equal overhead), so that A(i,j) = A(j,i). Thus only the entries on the (strictly) lower triangular portion of A will be supplied. 

The input to your program will be the lower triangular section of A. That is, the second line of input will contain one entry, A(2,1). The next line will contain two entries, A(3,1) and A(3,2), and so on.

Output

Your program should output the minimum communication time required to broadcast a message from the first processor to all the other processors.

Sample Input

5
50
30 5
100 20 50
10 x x 10

Sample Output

35

这个题目比较长,不太好读,但是理解后题意比较简单,就是告诉你下三角的邻接矩阵的关系,值代表权值,然后问你1到其他点的最短时间,此题的一个不太好做的点在于怎么读图,因为既有数字也有字符串,只能用字符串,不然x没法读然后转换成整数就用atoi函数就行了,其余就是裸的Dijstra了
代码:
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#define Inf 0x3f3f3f3f
 
using namespace std;
 
int map[1005][1005];
char G[10005][15];
 
int vis[1005],dis[1005];
int n,m;//n个点,m条边
 
void Init ()
{
    memset(map,Inf,sizeof(map));
    for(int i=1;i<=n;i++)
    {
        map[i][i]=0;
    }
}
 
void Getmap()
{
    int u,v,w;
    for(int t=0;t<(n)*(n-1)/2;t++)
    {
        scanf("%s",G[t]);
    }
    int cnt=0;
    for(int t=2;t<=n;t++)
    {
        for(int j=1;j<t;j++)
        {
            if(G[cnt][0]=='x')
            {
                w=Inf;
            }
            else
            {
                w=atoi(G[cnt]);
            }
            cnt++;
            if(map[t][j]>w)
            {
                map[t][j]=w;
                map[j][t]=w;
            }
        }
    }
    
}
 
void Dijkstra(int u)
{
    memset(vis,0,sizeof(vis));
    for(int t=1;t<=n;t++)
    {
        dis[t]=map[u][t];
    }
    vis[u]=1;
    for(int t=1;t<n;t++)
    {
        int minn=Inf,temp;
        for(int i=1;i<=n;i++)
        {
            if(!vis[i]&&dis[i]<minn)
            {
                minn=dis[i];
                temp=i;
            }
        }
        vis[temp]=1;
        for(int i=1;i<=n;i++)
        {
            if(map[temp][i]+dis[temp]<dis[i])
            {
                dis[i]=map[temp][i]+dis[temp];
            }
        }
    }
    
}
 
int main()
{
    cin>>n;
    Init();
    Getmap();
    Dijkstra(1);
    int maxx=0;
    for(int t=2;t<=n;t++)
    {
        maxx=max(dis[t],maxx);
    }
    cout<<maxx<<endl;
    //printf("%d\n",dis[1]);
    
    
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/Staceyacm/p/11111095.html