MPI Maelstrom(最短路,Dijkstra)

MPI Maelstrom

BIT has recently taken delivery of their new supercomputer, a 32 processor Apollo Odyssey distributed shared memory machine with a hierarchical communication subsystem. Valentine McKee’s research advisor, Jack Swigert, has asked her to benchmark the new system.
Since the Apollo is a distributed shared memory machine, memory access and communication times are not uniform,'' Valentine told Swigert.Communication is fast between processors that share the same memory subsystem, but it is slower between processors that are not on the same subsystem. Communication between the Apollo and machines in our lab is slower yet.”

“How is Apollo’s port of the Message Passing Interface (MPI) working out?” Swigert asked.

Not so well,'' Valentine replied.To do a broadcast of a message from one processor to all the other n-1 processors, they just do a sequence of n-1 sends. That really serializes things and kills the performance.”

“Is there anything you can do to fix that?”

Yes,'' smiled Valentine.There is. Once the first processor has sent the message to another, those two can then send messages to two other hosts at the same time. Then there will be four hosts that can send, and so on.”

“Ah, so you can do the broadcast as a binary tree!”

“Not really a binary tree – there are some particular features of our network that we should exploit. The interface cards we have allow each processor to simultaneously send messages to any number of the other processors connected to it. However, the messages don’t necessarily arrive at the destinations at the same time – there is a communication cost involved. In general, we need to take into account the communication costs for each link in our network topologies and plan accordingly to minimize the total time required to do a broadcast.”
Input
The input will describe the topology of a network connecting n processors. The first line of the input will be n, the number of processors, such that 1 <= n <= 100.

The rest of the input defines an adjacency matrix, A. The adjacency matrix is square and of size n x n. Each of its entries will be either an integer or the character x. The value of A(i,j) indicates the expense of sending a message directly from node i to node j. A value of x for A(i,j) indicates that a message cannot be sent directly from node i to node j.

Note that for a node to send a message to itself does not require network communication, so A(i,i) = 0 for 1 <= i <= n. Also, you may assume that the network is undirected (messages can go in either direction with equal overhead), so that A(i,j) = A(j,i). Thus only the entries on the (strictly) lower triangular portion of A will be supplied.

The input to your program will be the lower triangular section of A. That is, the second line of input will contain one entry, A(2,1). The next line will contain two entries, A(3,1) and A(3,2), and so on.
Output
Your program should output the minimum communication time required to broadcast a message from the first processor to all the other processors.
Sample Input
5
50
30 5
100 20 50
10 x x 10
Sample Output
35

题目链接:https://cn.vjudge.net/contest/242149#problem/B

题目大意是,n个计算机之间网络通信,给你一个下三角矩阵,其中x代表不能通信,一台编号为i的计算机默认和自己的通讯时间为0,即A(i, i) = 0。并且每一条边都是双向边,让你计算从第一台处理器到其余n-1个处理器 i 通讯时间(1到 i 通讯所用的最短时间)最长的一个。
这里通讯时间不可能是负数,所以直接可以用Dijkstra算法,输入的时候需要处理一下,atoi()函数可以将字符串转换成数字,头文件是 stdlib.h。
对了,一定要注意初始化一定要对,大部分的问题都出在这,我就在初始化找了好久的bug。

下面是代码:

#include<cstdio>
#include<cstring>
#include<stdlib.h>
#include<iostream>
using namespace std;
const int maxn = 105;
const int inf = 0x3f3f3f3f;

int e[maxn][maxn], dis[maxn], book[maxn];
int n;

void init()
{
    memset(e, inf, sizeof(e));
    memset(book, 0, sizeof(book));
    memset(dis, inf, sizeof(dis));
}

void Dijkstra()
{
    dis[1] = 0;
    int minx, minv;
    for(int i = 1; i <= n; i++)
    {
        minx = inf;
        for(int i = 1; i <= n; i++)
        {
            if(book[i]) continue ;
            if(dis[i] < minx)
            {
                minx = dis[i];
                minv = i;
            }
        }
        book[minv] = 1;
        for(int i = 1; i <= n; i++)
        {
            if(book[i] || !e[minv][i])  continue ;
            dis[i] = min(minx + e[minv][i], dis[i]);
        }
    }
}

int main()
{
    while(~scanf("%d", &n))
    {
        getchar();
        init();
        for(int i = 1; i <= n-1; i++)
            for(int j = 1; j <= i; j++)
            {
                char s[20];
                scanf("%s", s);
                if(strcmp(s, "x") != 0)
                    e[i+1][j] = e[j][i+1] = atoi(s);  //把字符串转化为整型
            }
        for(int i = 1; i <= n; i++) e[i][i] = 0;
        Dijkstra();
        int _max = -1;
        for(int i = 1;i <= n; i++)
            if(_max < dis[i])   _max = dis[i];
        printf("%d\n", _max);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_40788897/article/details/81324770
今日推荐