HDU 2614 Beat

版权声明:本文为博主原创文章,转载时请附上博主网址。 https://blog.csdn.net/jiayizhenzhenyijia/article/details/88647762

题目链接:传送门

Problem Description

Zty is a man that always full of enthusiasm. He wants to solve every kind of difficulty ACM problem in the world. And he has a habit that he does not like to solve
 a problem that is easy than problem he had solved. Now yifenfei give him n difficulty problems, and tell him their relative time to solve it after solving the other one.
 You should help zty to find a order of solving problems to solve more difficulty problem. 
You may sure zty first solve the problem 0 by costing 0 minute. Zty always choose cost more or equal time’s problem to solve.


Input

The input contains multiple test cases.
Each test case include, first one integer n ( 2< n < 15).express the number of problem.
Than n lines, each line include n integer Tij ( 0<=Tij<10), the i’s row and j’s col integer Tij express after solving the problem i, will cost Tij minute to solve the problem j.


Output

For each test case output the maximum number of problem zty can solved.


Sample Input

3
0 0 0
1 0 1
1 0 0
3
0 2 2
1 0 1
1 1 0
5
0 1 2 3 1
0 0 2 3 1
0 0 0 3 1
0 0 0 0 2
0 0 0 0 0

Sample Output

3
2
4
Hint

Hint: sample one, as we know zty always solve problem 0 by costing 0 minute. 
So after solving problem 0, he can choose problem 1 and problem 2, because T01 >=0 and T02>=0. 
But if zty chooses to solve problem 1, he can not solve problem 2, because T12 < T01. 
So zty can choose solve the problem 2 second, than solve the problem 1.  

题目大意:给你一个数s,接下来是个s*s的矩阵,m[i][j]表示做过题i后题j的难度,下一题的难度一定要大于等于上一题难度,问最多做几道题。给的数据范围比较小,直接暴力搜索即可。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int m[25][25],n[25];
int s,w,z;
void dfs(int a,int b,int c)
{
	if(b>w)
		w=b;
	if(w==s)
		return ;
	int d,e,f;
	for(d=1;d<s;d++)
	{
		if(!n[d]&&m[a][d]>=c)
		{
			n[d]=1;
			dfs(d,b+1,m[a][d]);
			n[d]=0;
		}
	}
}
int main()
{
	int a,b,c,d,e,f,g;
	while(cin>>s)
	{
		for(a=0;a<s;a++)
		{
			for(b=0;b<s;b++)
				cin>>m[a][b];
		}
		memset(n,0,sizeof(n));
		w=0;
		n[0]=1;
		for(c=1;c<s;c++)
		{
			n[c]=1;
			dfs(c,2,m[0][c]);
			n[c]=0;
		}
		cout<<w<<endl;
	}
}


 

猜你喜欢

转载自blog.csdn.net/jiayizhenzhenyijia/article/details/88647762