Beat——hdu2614

Zty is a man that always full of enthusiasm. He wants to solve every kind of difficulty ACM problem in the world. And he has a habit that he does not like to solve
a problem that is easy than problem he had solved. Now yifenfei give him n difficulty problems, and tell him their relative time to solve it after solving the other one.
You should help zty to find a order of solving problems to solve more difficulty problem.
You may sure zty first solve the problem 0 by costing 0 minute. Zty always choose cost more or equal time’s problem to solve.
Input
The input contains multiple test cases.
Each test case include, first one integer n ( 2< n < 15).express the number of problem.
Than n lines, each line include n integer Tij ( 0<=Tij<10), the i’s row and j’s col integer Tij express after solving the problem i, will cost Tij minute to solve the problem j.
Output
For each test case output the maximum number of problem zty can solved.

Sample Input
3
0 0 0
1 0 1
1 0 0
3
0 2 2
1 0 1
1 1 0
5
0 1 2 3 1
0 0 2 3 1
0 0 0 3 1
0 0 0 0 2
0 0 0 0 0
Sample Output
3
2
4

Hint
Hint: sample one, as we know zty always solve problem 0 by costing 0 minute.
So after solving problem 0, he can choose problem 1 and problem 2, because T01 >=0 and T02>=0.
But if zty chooses to solve problem 1, he can not solve problem 2, because T12 < T01.
So zty can choose solve the problem 2 second, than solve the problem 1.

题解:
其实就是一道深搜题,但是以前没有做过,所以花了很多时间但是一直做不出来。给我感觉如果一直做不出来,可以看一下答案,不要一直死磕,沉浸在自己的思路里,浪费时间。
深搜其实就是要递推。这题先在做出第0题的前提下,从第0行开始深搜,然后找出最大值。

import java.util.Scanner;
public class Main {
	static boolean[]vis=new boolean[20];
	static int n;
	static int max=1;
	static int[][]maze;
	
	public static void main(String[] args) {
		Scanner input=new Scanner(System.in);
		maze=new int[16][16];
		
		while(input.hasNext()) {
			n=input.nextInt();
			vis[0]=true;
			for(int i=0;i<n;i++){
				for(int j=0;j<n;j++){
					maze[i][j]=input.nextInt();
				}
			}
			
			max=Math.max(max, dfs(0,0,1));
			
			
			System.out.println(max);
			max=1;
		}
		
	}
	
	public static int dfs(int line,int tp,int t){
		
		for(int i=0;i<n;i++){
			if(vis[i]==true||line==i)continue;
			
			if(maze[line][i]>=tp){
				
				vis[i]=true;
				dfs(i,maze[line][i],t+1);
				max=Math.max(max, t+1);
				vis[i]=false;
			}
		}
		return max;
	}
}

猜你喜欢

转载自blog.csdn.net/weixin_43910096/article/details/87824753