哈夫曼树 模板+例题

核心代码

while (q.size() > 1) {
        x = q.top();
        q.pop();
        x += q.top();
        q.pop();
        q.push(x);
        sum += x;
    }

Problem A Fence Repair (POJ \(3253\))

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (\(1 \leq N \leq 20,000\)) planks of wood, each having some integer length \(L_i\) (\(1 \leq L_i \leq 50,000\)) units. He then purchases a single long board just long enough to saw into the \(N\) planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

Input

Line \(1\): One integer \(N\), the number of planks
Lines \(2\)..\(N+1\): Each line contains a single integer describing the length of a needed plank

Output

Line \(1\): One integer: the minimum amount of money he must spend to make \(N-1\) cuts

Sample Input

\(3\)

\(8\)

\(5\)

\(8\)

Sample Output

\(34\)

Hint

He wants to cut a board of length \(21\) into pieces of lengths \(8\), \(5\), and \(8\).The original board measures \(8+5+8=21\). The first cut will cost \(21\), and should be used to cut the board into pieces measuring \(13\) and \(8\).The second cut will cost \(13\), and should be used to cut the \(13\) into \(8\) and \(5\). This would cost \(21+13=34\). If the \(21\) was cut into \(16\) and \(5\) instead, the second cut would cost 16 for a total of \(37\) (which is more than \(34\)).

Description

FJ要修补围栏,他需要\(n\)块长度为\(L_i\)的木头。开始时,有一块无限长的木板需要锯成\(n\)块长度为\(L_i\)的木板,收费的标准为每次锯出的长度。求总价值最小。

Solution

这题显然是\(Huffman\)树的模板题。先在\(N\) \(planks\)中每次找出两块长度最短的木板,把他们合并,并放进集合\(A\)中,然后再集合\(A\)中找出两块长度最短的木板,合并继续放进集合中,一直重复这个过程,直到集合中只剩下一个元素。

#include<bits/stdc++.h>
using namespace std;
int n, x;
long long sum;
priority_queue<int,vector<int>,greater<int> >q;
int main() {
    scanf("%d", &n);
    for (int i = 1; i <= n; i++) {
        scanf("%d", &x);
        q.push(x);
    }
    if (q.size() == 1) {
        sum += q.top();
        q.pop();
    }
    while (q.size() > 1) {
        x = q.top();
        q.pop();
        x += q.top();
        q.pop();
        q.push(x);
        sum += x;
    }
    printf("%lld\n", sum);
    return 0;
}

//被强制要求写的可还行

猜你喜欢

转载自www.cnblogs.com/wjnclln/p/11070208.html