Beauty of Array(找规律)

Edward has an array A with N integers. He defines the beauty of an array as the summation of all distinct integers in the array. Now Edward wants to know the summation of the beauty of all contiguous subarray of the array A.

Input

There are multiple test cases. The first line of input contains an integer Tindicating the number of test cases. For each test case:

The first line contains an integer N (1 <= N <= 100000), which indicates the size of the array. The next line contains N positive integers separated by spaces. Every integer is no larger than 1000000.

Output

For each case, print the answer in one line.

Sample Input

3
5
1 2 3 4 5
3
2 3 3
4
2 3 3 2

Sample Output

105
21
38

【分析】题意为,计算一个序列的连续子序列的和,并且如果有相等的数字的话,只加一次。

e.g. 如序列 1 2 3 4 3
    

以1结尾:1

sum[1]=1=(1-0)*1

以2结尾:12  2

sum[2]=1+2+2=sum[1]+2*2=sum[1]+(2-0)*2

以3结尾:123  23  3

sum[3]=1+2+3+...=sum[2]+3*3=sum[2]+(3-0)*3

以4结尾:1234  234  34  4

sum[4]=1+2+3+...=sum[3]+4*4=sum[3]+(4-0)*4
以3结尾:12343  2343  343  43  3    sum[5]=1+2+3+...=sum[4]+2*3=sum[4]+(5-3)*3
   

sum[i]=sum[i-1] + (i - pos[x] )*x;    //上一次的和+(该位置-该数上一次出现的位置)*该数(pos均初始为0,i 从1开始)

#include<bits/stdc++.h>

using namespace std;
typedef long long ll;
int pos[100010];

int main()
{
	int t;
	scanf("%d",&t);
	while (t--)
	{
		int n,x;
		ll sum = 0,ans = 0;
		scanf("%d",&n);
		memset(pos,0,sizeof(pos));
		for (int i=1;i<=n;i++)
		{
			scanf("%d",&x);
			sum += (i-pos[x]) * x;
			ans += sum;
			pos[x] = i;
		}
		printf("%lld\n",ans);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_40912854/article/details/89062351
今日推荐