程设作业之递归

A:Boolean Expressions

总时间限制: 
1000ms
 
内存限制: 
65536kB
描述
The objective of the program you are going to produce is to evaluate boolean expressions as the one shown next: 
Expression: ( V | V ) & F & ( F | V )

where V is for True, and F is for False. The expressions may include the following operators: ! for not , & for and, | for or , the use of parenthesis for operations grouping is also allowed. 

To perform the evaluation of an expression, it will be considered the priority of the operators, the not having the highest, and the or the lowest. The program must yield V or F , as the result for each expression in the input file. 
输入
The expressions are of a variable length, although will never exceed 100 symbols. Symbols may be separated by any number of spaces or no spaces at all, therefore, the total length of an expression, as a number of characters, is unknown. 

The number of expressions in the input file is variable and will never be greater than 20. Each expression is presented in a new line, as shown below. 
输出
For each test expression, print "Expression " followed by its sequence number, ": ", and the resulting value of the corresponding test expression. Separate the output for consecutive test expressions with a new line. 

Use the same format as that shown in the sample output shown below. 
样例输入
( V | V ) & F & ( F| V)
!V | V & V & !F & (F | V ) & (!F | F | !V & V)
(F&F|V|!V&!F&!(F|F&V))
样例输出
Expression 1: F
Expression 2: V
Expression 3: V
代码如下:
#include <iostream>
#include <cstring>
using namespace std;

char a[100]={0};
char b[100]={0};
int m;

void deletespace()
{
     int num=0;
     for (int i=0;i<m;i++)
     {
          if(a[i]!=' ')
              b[num++]=a[i];
          else
          continue;
     }
     return;
}

bool solve(int x,int y)   //x为起始,y为结束
{
     int kh=0;
     for (int i=x;i<=y;i++)
     {
         if(b[i]=='(')
          kh++;
          if(b[i]==')')
          kh--;
          if (b[i]=='|'&&kh==0)
          return (solve(x,i-1)||solve(i+1,y));
     } 
     for (int i=x;i<=y;i++)
     {
         if(b[i]=='(')
          kh++;
          if(b[i]==')')
          kh--;
          if (b[i]=='&'&&kh==0)
          return (solve(x,i-1)&&solve(i+1,y));
     } 
     if (b[x]=='!')
     return !solve(x+1,y);
     if (b[x]=='(')
     return solve(x+1,y-1);
     if (b[x]=='V')
     return 1;
     if (b[x]=='F')
     return 0; 
}

int main(){
    int time=0;
     while(cin.getline(a,100))
     {
         time++;
          if(strlen(a)==0)
          continue;
          m=strlen(a);
          deletespace();          //输入处理完成,将a转换为b 
          int t=strlen(b)-1;
          cout << "Expression "<< time <<  ": ";
          if (solve(0,t))
          cout << "V"<< endl;
          else  
          cout << "F"<< endl;
  memset(a,0,sizeof(a));
  memset(b,0,sizeof(b));
 }
 return 0; 
}
View Code






 

猜你喜欢

转载自www.cnblogs.com/shukai2000/p/10987081.html