Bone Collector II HDU - 2639

The title of this problem is familiar,isn't it?yeah,if you had took part in the "Rookie Cup" competition,you must have seem this title.If you haven't seen it before,it doesn't matter,I will give you a link: 

Here is the link:  http://acm.hdu.edu.cn/showproblem.php?pid=2602 

Today we are not desiring the maximum value of bones,but the K-th maximum value of the bones.NOTICE that,we considerate two ways that get the same value of bones are the same.That means,it will be a strictly decreasing sequence from the 1st maximum , 2nd maximum .. to the K-th maximum. 

If the total number of different values is less than K,just ouput 0.

InputThe first line contain a integer T , the number of cases. 
Followed by T cases , each case three lines , the first line contain two integer N , V, K(N <= 100 , V <= 1000 , K <= 30)representing the number of bones and the volume of his bag and the K we need. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone. 
OutputOne integer per line representing the K-th maximum of the total value (this number will be less than 2 31). 
Sample Input

3
5 10 2
1 2 3 4 5
5 4 3 2 1
5 10 12
1 2 3 4 5
5 4 3 2 1
5 10 16
1 2 3 4 5
5 4 3 2 1

Sample Output

12
2
0

HDU-2602的变形题,不再是求最优解,而是求第K优解,所以可以维护两个数组a,b a记录放第i个物品的情况,b记录不放第i个物品的情况。
从这两个数组中选出前K个最优解,记录在dp数组中。

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

int c[105], w[105];
int dp[1005][31];
int a[31],b[31];

int main(){
    int t, n, v, k;
    scanf("%d",&t);
    while(t--){
        memset(dp,0,sizeof(dp));
        scanf("%d%d%d",&n,&v,&k);
        for(int i=0;i<n;i++)
            scanf("%d",&w[i]);
        for(int i=0;i<n;i++)
            scanf("%d",&c[i]);
        for(int i=0;i<n;i++){
            for(int j=v;j>=c[i];j--){
                for(int cnt=1;cnt<=k;cnt++){
                    // a 放 b 不放
                    a[cnt] = dp[j-c[i]][cnt]+w[i];
                    b[cnt] = dp[j][cnt];
                }
                a[k+1] = b[k+1] = -1;
                for(int cnt=1,x=1,y=1;cnt<=k&&(x<=k||y<=k);){
                    if(a[x]>b[y]){
                        dp[j][cnt] = a[x++];
                    }else
                        dp[j][cnt] = b[y++];
                    if(dp[j][cnt]!=dp[j][cnt-1])
                        cnt++;
                }
            }
        }
        printf("%d\n",dp[v][k]);
    }
    return 0;
}
View Code

猜你喜欢

转载自www.cnblogs.com/kongbb/p/10927671.html