【数通学习】【二层交换】mstp协议学习

MSTP兼STP和RSTP,通过多实例能实现对业务流量和用户流量的隔离,同时还提供了数据转发的多个冗余路径,在数据转发的过程中实现VLAN数据的负载均衡。

在MSTP中,可以将多个VLAN映射到一个实例instance,MSTP将为 每个instance运行一颗生成树,可以基于instance设置优先级、端口路径开销等参数。

配置样例:

上面这个示例展示了在网络中存在四个vlan,分别时10,20,30,40(别问vlan是什么,vlan就是一个小的广播域,vlan中的机器可以进行二层通讯不受阻碍;但vlan外的机器要和vlan中的机器通讯,要走三层交换才能通讯,后半句可能不准确,请见谅。)

这个二层网络上,存在一个环路为了消除环路,我们需要使用 MSTP技术把SW3的端口阻塞掉。

因为MSTP具有将vlan分组,一个分组可以对应一个生成树实例,可以减少生成树的数量,减少资源占用率。

其中,10和20这两个vlan被 绑定到了生成树实例1上,且SW1是主根,SW2是从根。

而,30和40则被绑定到了生成 树 实例 2上,且SW2是主根,SW1是从根。

下面是基本的配置:

W1配置:
vlan batch 10 20 30 40 // 创建vlan
stp mode mstp // 将生成树模式设置为MSTP
stp region-configuration // 进入mstp配置视图
region-name huawei // MSTP域名为huawei
revision-level 1 // 修订号
instance 1vlan 10 20 // 配置vlan到实例的映射
instance 2 vlan 30 40 // 配置vlan到实例的映射
active region-configuaration // 激活MSTP域的配置
quit
stp instance 1 root primary // 设置实例1为主根
stp instance 2 root secondary // 设置 实例2为从根
stp enable

interface g 0/0/24
port link-type trunk
port trunk allow-pass vlan 10 20 30 40
interface g 0/0/22
port link-type trunk
port trunk allow-pass vlan 10 20 30 40

sw2配置和SW1配置基本相同,只是主根和次根配置相反

sw3配置:
vlan batch 10 20 30 40
stp mode mstp
stp region-configuration
region-name huawei
instance 1 vlan 10 20
instance 2 vlan 30 40
active region-configuration
quit

下面进行演示,演示可能和上面的命令行有些不一样,主要是端口没有按照上面的使用。

首先在拓扑图上创建三个交换机,用线缆把他们连接起来,并且启动设备:

打开LSW1的命令行,先修改一下设备名称:

然后创建VLAN:

 

 设置生成树模式为MSTP,其实默认就是MSTP:

下面进入stp视图:

修改MSTP域名为weixian、设置修订号:

将vlan 10和20分组到实例1上,将vlan  30和40分组到实例2上:

然后激活MSTP域的设置并退出:

设置主根和从根,并使能STP:

 

SW1的MSTP的配置结束了,下面给他配一下接口,因为他的端口需要走10,20,30,40四个vlan,需要配置为trunk模式,并且允许vlan通过:

 

SW2的配置和SW1的配置基本一致,只是在设置主根和从根的时候和SW1是相反的:

 

SW3的配置就很简单了 :

 

以上,整个配置就 完成了,下面我们查看MSTP的摘要信息:

SW1:

对于实例1来说 ,端口都是指定节点,都处于转发状态,未阻塞。

杜宇实例2来说,SW1不是主节点,所以24号端口是主根节点,端口也都处于转发状态。

SW2:

SW2刚好相反。

SW3:

对于实例1来说,它的24号端口阻塞了;对于实例2来说,它 的23号端口阻塞了。

 

猜你喜欢

转载自www.cnblogs.com/wuyizuokan/p/10924506.html