Color the ball(树状数组区间更新+单点求值)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1556

Color the ball

Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 32297    Accepted Submission(s): 15618


Problem Description
N个气球排成一排,从左到右依次编号为1,2,3....N.每次给定2个整数a b(a <= b),lele便为骑上他的“小飞鸽"牌电动车从气球a开始到气球b依次给每个气球涂一次颜色。但是N次以后lele已经忘记了第I个气球已经涂过几次颜色了,你能帮他算出每个气球被涂过几次颜色吗?
 
Input
每个测试实例第一行为一个整数N,(N <= 100000).接下来的N行,每行包括2个整数a b(1 <= a <= b <= N)。
当N = 0,输入结束。
 
Output
每个测试实例输出一行,包括N个整数,第I个数代表第I个气球总共被涂色的次数。
 
Sample Input
3 1 1 2 2 3 3 3 1 1 1 2 1 3 0
 
Sample Output
1 1 1 3 2 1
 
思路:线段树 树状数组都可以写,这里只存树状数组的,为的是怕即将到来的邀请赛卡空间,线段树不能写。
看代码:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long LL;
const LL mod=1e9+7;
const LL INF=1e9+7;
const int maxn=100000+50;
int c[maxn];
int N;
int lowbit(int x)
{
    return x&(-x);
}
void Update(int x,int add)
{
    while(x>0)
    {
        c[x]+=add;
        x-=lowbit(x);
    }
}
int sum(int x)
{
    int ret=0;
    while(x<=N)
    {
        ret+=c[x];
        x+=lowbit(x);
    }
    return ret;
}
int main()
{

    while(scanf("%d",&N)!=EOF)
    {
        if(N==0) break;
        memset(c,0,sizeof(c));
        int M=N;
        while(M--)
        {
            int a,b;
            scanf("%d%d",&a,&b);
            Update(b,1);
            Update(a-1,-1);
        }
        printf("%d",sum(1));
        for(int i=2;i<=N;i++) printf(" %d",sum(i));
        printf("\n");
    }
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/caijiaming/p/10885880.html