字符串替换 (15 分)

版权声明:作者:最美的风景是你 https://blog.csdn.net/qq_43720467/article/details/90105530

字符串替换 (15 分)

本题要求编写程序,将给定字符串中的大写英文字母按以下对应规则替换:

原字母 对应字母
A Z
B Y
C X
D W
… …
X C
Y B
Z A

输入格式:

输入在一行中给出一个不超过80个字符、并以回车结束的字符串。

输出格式:

输出在一行中给出替换完成后的字符串。

输入样例:

Only the 11 CAPItaL LeTtERS are replaced.

Only the 11 CAPItaL LeTtERS are replaced.

输出样例:

Lnly the 11 XZKRtaO OeGtVIH are replaced.

#include<stdio.h>
#include<string.h>
int main()
{
    char a[81];
    int i;
    gets(a);
    for(i=0;a[i]!='\0';i++){
    if(a[i]>='A'&&a[i]<='Z') a[i]='Z'-(a[i]-'A');
    }
    puts(a);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_43720467/article/details/90105530
今日推荐