习题7-7 字符串替换 (15分)

本题要求编写程序,将给定字符串中的大写英文字母按以下对应规则替换:

原字母 对应字母
A Z
B Y
C X
D W
X C
Y B
Z A

输入格式:

输入在一行中给出一个不超过80个字符、并以回车结束的字符串。

输出格式:

输出在一行中给出替换完成后的字符串。

输入样例:

Only the 11 CAPItaL LeTtERS are replaced.

输出样例:

Lnly the 11 XZKRtaO OeGtVIH are replaced.

解答:

#include<stdio.h>
#include<string.h>
int main(){
    char s[85];
    char c;
    char a[]={'Z'};
    scanf("%[^\n]",&s);
    int len=strlen(s);
    for(int i=0;i<len;i++){
        if(s[i]>='A'&&s[i]<='Z'){
            printf("%c",155 - s[i]);
        }else{
            printf("%c",s[i]);
        }
    }
    return 0;
}
发布了98 篇原创文章 · 获赞 2 · 访问量 3720

猜你喜欢

转载自blog.csdn.net/qq_30377869/article/details/104806725
今日推荐