POJ-2769 Feel Good (单调栈)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/chimchim04/article/details/89455613

Feel Good

题目链接:http://poj.org/problem?id=2796

Description

Bill is developing a new mathematical theory for human emotions. His recent investigations are dedicated to studying how good or bad days influent people's memories about some period of life. 

A new idea Bill has recently developed assigns a non-negative integer value to each day of human life. 

Bill calls this value the emotional value of the day. The greater the emotional value is, the better the daywas. Bill suggests that the value of some period of human life is proportional to the sum of the emotional values of the days in the given period, multiplied by the smallest emotional value of the day in it. This schema reflects that good on average period can be greatly spoiled by one very bad day. 

Now Bill is planning to investigate his own life and find the period of his life that had the greatest value. Help him to do so.

Input

The first line of the input contains n - the number of days of Bill's life he is planning to investigate(1 <= n <= 100 000). The rest of the file contains n integer numbers a1, a2, ... an ranging from 0 to 106 - the emotional values of the days. Numbers are separated by spaces and/or line breaks.

Output

Print the greatest value of some period of Bill's life in the first line. And on the second line print two numbers l and r such that the period from l-th to r-th day of Bill's life(inclusive) has the greatest possible value. If there are multiple periods with the greatest possible value,then print any one of them.

Sample Input

6
3 1 6 4 5 2

Sample Output

60
3 5

Source

Northeastern Europe 2005

扫描二维码关注公众号,回复: 6191144 查看本文章

题目大意:求区间最小值与区间和乘积的最大值

思路:单调栈,求出以ai为最小值,向左向右延伸的最长区间,ai与区间和的乘积,若大于之前的最大值,更新答案

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define ll long long
const int N=100005;
int s[N];
ll a[N],sum[N];
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        for(int i=0;i<n;i++)
        {
            scanf("%lld",&a[i]);
            sum[i]=a[i];
            if(i)
            sum[i]+=sum[i-1];
        }
        a[n]=-1;
        int top=0,l,r;
        ll ans=0;
        for(int i=0;i<=n;i++)
        {
            if(top==0||a[s[top]]<=a[i])
                s[++top]=i;
            else
            {
                while(top&&a[i]<a[s[top]])
                {
                    ll tmp=a[s[top]]*(sum[i-1]-sum[s[top]-1]);
                    if(ans<=tmp)
                    {
                        ans=tmp;
                        l=s[top]+1;
                        r=i;
                    }
                    --top;
                }
                ++top;
                a[s[top]]=a[i];
            }
        }
        printf("%lld\n",ans);
        printf("%d %d\n",l,r);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/chimchim04/article/details/89455613
今日推荐