Abbreviation


In the Test of English as a Foreign Language (TOEFL), the listening part is very important but also very hard for most students since it is usually quite hard for them to remember the whole passage. To help themselves memorize the content, students can write down some necessary details. However, it is not easy to write down the complete word because of its length. That's why we decide to use the abbreviation to express the whole word.

It is very easy to get the abbreviation, all we have to do is to keep the consonant letters and erase the vowel. In the English alphabet, we regard 'a', 'e', 'i', 'y', 'o', 'u' as the vowels and the other letters as the consonants. For example, "subconscious" will be expressed as "sbcnscs".

However, there is one exception: if the vowel appears as the first letter, they should be kept instead of thrown away. For example, "oipotato" should be expressed as "optt".

Since you have learned how to use the abbreviation method, it's time for some exercises. We now present you words in total, it's your task to express them in their abbreviation form.

Input

There are multiple test cases. The first line of the input contains an integer (about 100), indicating the number of test cases. For each test case:

The only line contains a string () consisting of lowercase English letters, indicating the word which needs to be abbreviated.

Output

For each test case output one line containing one string, which is the correct abbreviation of the given word.

Sample Input

5
subconscious
oipotato
word
symbol
apple

Sample Output

sbcnscs
optt
wrd
smbl
appl

#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;
const int maxn=105;
char ch[]="aeiouy";
char s[maxn];

void solve(){
    int T;
    scanf("%d",&T);
    while(T--){
        scanf("%s",s);
        int len=strlen(s);
        printf("%c",s[0]);
        for(int i=1;i<len;i++){
            int flag=1;
            for(int j=0;j<6;j++){
                if(s[i]==ch[j]){
                    flag=0;break;
                }
            }
            if(flag)    printf("%c",s[i]);
        }
        printf("\n");
    }
}
int main(){
    solve();
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_43497140/article/details/89606564
今日推荐