HDU 3535 AreYouBusy

版权声明:如果转载,请注明出处。 https://blog.csdn.net/S_999999/article/details/89608383

AreYouBusy

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5505    Accepted Submission(s): 2201


 

Problem Description

Happy New Term!
As having become a junior, xiaoA recognizes that there is not much time for her to AC problems, because there are some other things for her to do, which makes her nearly mad.
What's more, her boss tells her that for some sets of duties, she must choose at least one job to do, but for some sets of things, she can only choose at most one to do, which is meaningless to the boss. And for others, she can do of her will. We just define the things that she can choose as "jobs". A job takes time , and gives xiaoA some points of happiness (which means that she is always willing to do the jobs).So can you choose the best sets of them to give her the maximum points of happiness and also to be a good junior(which means that she should follow the boss's advice)?

 

Input

There are several test cases, each test case begins with two integers n and T (0<=n,T<=100) , n sets of jobs for you to choose and T minutes for her to do them. Follows are n sets of description, each of which starts with two integers m and s (0<m<=100), there are m jobs in this set , and the set type is s, (0 stands for the sets that should choose at least 1 job to do, 1 for the sets that should choose at most 1 , and 2 for the one you can choose freely).then m pairs of integers ci,gi follows (0<=ci,gi<=100), means the ith job cost ci minutes to finish and gi points of happiness can be gained by finishing it. One job can be done only once.

 

Output

One line for each test case contains the maximum points of happiness we can choose from all jobs .if she can’t finish what her boss want, just output -1 .

 

Sample Input

 

3 3

2 1

2 5

3 8

2 0

1 0

2 1

3 2

4 3

2 1

1 1

3 4

2 1

2 5

3 8

2 0

1 1

2 8

3 2

4 4

2 1

1 1

1 1

1 0

2 1

5 3

2 0

1 0

2 1

2 0

2 2

1 1

2 0

3 2

2 1

2 1

1 5

2 8

3 2

3 8

4 9

5 10

 

Sample Output

 

5

13

-1

-1

题意:

解题思路:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
using namespace std;
const int maxn=100+5;
#define INF 1e8
 
int n;
int t;
int dp[maxn][maxn];
int cost[maxn];
int val[maxn];
 
int main(){
    while(cin>>n>>t){
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=n;i++){
            int m,s;
            cin>>m>>s;
            for(int j=1;j<=m;j++)
                cin>>cost[j]>>val[j];
            if(s==0){
                for(int j=0;j<=t;j++)  //肯定改到t啊
                    dp[i][j]=-INF;
                for(int j=1;j<=m;j++){
                    for(int k=t;k>=cost[j];k--){
                        dp[i][k]=max(dp[i][k-cost[j]]+val[j],dp[i][k]);
                        dp[i][k]=max(dp[i-1][k-cost[j]]+val[j],dp[i][k]);
                    }
                }
            }
            else if(s==1){
                for(int j=0;j<=t;j++)
                    dp[i][j]=dp[i-1][j];
                for(int j=1;j<=m;j++)
                    for(int k=t;k>=cost[j];k--)
                        dp[i][k]=max(dp[i][k],dp[i-1][k-cost[j]]+val[j]);
            }
            else if(s==2){
                for(int j=0;j<=t;j++)
                    dp[i][j]=dp[i-1][j];
                for(int j=1;j<=m;j++)
                    for(int k=t;k>=cost[j];k--){
                        dp[i][k]=max(dp[i][k-cost[j]]+val[j],dp[i][k]);
                        dp[i][k]=max(dp[i-1][k-cost[j]]+val[j],dp[i][k]);
                    }
            }
        }
        int ans=max(dp[n][t],-1);
        cout<<ans<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/S_999999/article/details/89608383
hdu
今日推荐