POJ 2632 Crashing Robots(模拟)

版权声明:本文为博主原创文章,欢迎转载。如有问题,欢迎指正。 https://blog.csdn.net/weixin_42172261/article/details/89524979

In a modernized warehouse, robots are used to fetch the goods. Careful planning is needed to ensure that the robots reach their destinations without crashing into each other. Of course, all warehouses are rectangular, and all robots occupy a circular floor space with a diameter of 1 meter. Assume there are N robots, numbered from 1 through N. You will get to know the position and orientation of each robot, and all the instructions, which are carefully (and mindlessly) followed by the robots. Instructions are processed in the order they come. No two robots move simultaneously; a robot always completes its move before the next one starts moving.
A robot crashes with a wall if it attempts to move outside the area of the warehouse, and two robots crash with each other if they ever try to occupy the same spot.
Input
The first line of input is K, the number of test cases. Each test case starts with one line consisting of two integers, 1 <= A, B <= 100, giving the size of the warehouse in meters. A is the length in the EW-direction, and B in the NS-direction.
The second line contains two integers, 1 <= N, M <= 100, denoting the numbers of robots and instructions respectively.
Then follow N lines with two integers, 1 <= Xi <= A, 1 <= Yi <= B and one letter (N, S, E or W), giving the starting position and direction of each robot, in order from 1 through N. No two robots start at the same position.
在这里插入图片描述
Figure 1: The starting positions of the robots in the sample warehouse
Finally there are M lines, giving the instructions in sequential order.
An instruction has the following format:
< robot #> < action> < repeat>
Where is one of
L: turn left 90 degrees,
R: turn right 90 degrees, or
F: move forward one meter,
and 1 <= < repeat> <= 100 is the number of times the robot should perform this single move.
Output
Output one line for each test case:
Robot i crashes into the wall, if robot i crashes into a wall. (A robot crashes into a wall if Xi = 0, Xi = A + 1, Yi = 0 or Yi = B + 1.)
Robot i crashes into robot j, if robots i and j crash, and i is the moving robot.
OK, if no crashing occurs.
Only the first crash is to be reported.
Sample Input
4
5 4
2 2
1 1 E
5 4 W
1 F 7
2 F 7
5 4
2 4
1 1 E
5 4 W
1 F 3
2 F 1
1 L 1
1 F 3
5 4
2 2
1 1 E
5 4 W
1 L 96
1 F 2
5 4
2 3
1 1 E
5 4 W
1 F 4
1 L 1
1 F 20
Sample Output
Robot 1 crashes into the wall
Robot 1 crashes into robot 2
OK
Robot 1 crashes into robot 2

需要注意的是这个题用的是坐标轴,坐标轴绕点1,1顺时针转90度才对应于数组的排列方式。
所以在坐标周中向北走1格,相当于在数组中x不动,j+1。其他方向同理推出

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

int map[105][105];
typedef struct{
	int x, y;
	int dir;//0,1,2,3-->N, W, S, E
}node;
node rob[105];
int move[4][2]={{0,1},{-1,0},{0,-1},{1,0}};//分别对应于坐标轴的上左下右

int main()
{
	int t;
	int A, B, N, M;
	char s[5];
	scanf("%d", &t);
	while (t--){
		memset(map, 0, sizeof(map));
		scanf("%d%d", &A, &B);
		scanf("%d%d", &N, &M);
		for (int i=1; i<=N; i++){
			scanf("%d%d%s", &rob[i].x, &rob[i].y, s);
			if (s[0]=='N')	rob[i].dir=0;
			if (s[0]=='W')	rob[i].dir=1;
			if (s[0]=='S')	rob[i].dir=2;
			if (s[0]=='E')	rob[i].dir=3;
			map[rob[i].x][rob[i].y]=i;
		}
		int t1, t2;
		int flag=0;
		while (M--){
			scanf("%d%s%d", &t1, s, &t2);
			if (flag==1)	continue;
			if (s[0]=='L'){
				rob[t1].dir+=t2;
				rob[t1].dir%=4;
			}else if (s[0]=='R'){
				rob[t1].dir-=t2;
                rob[t1].dir%=4;
                rob[t1].dir=(rob[t1].dir+4)%4;
			}else{
				while (t2--){
					int tx=rob[t1].x;
					int ty=rob[t1].y;
					tx+=move[rob[t1].dir][0];
					ty+=move[rob[t1].dir][1];
					if (tx<=0||tx>A||ty<=0||ty>B){
						printf("Robot %d crashes into the wall\n", t1);
						flag=1;
						break;
					}else if (map[tx][ty]!=0){
						printf("Robot %d crashes into robot %d\n", t1 ,map[tx][ty]);
						flag=1;
						break;
					}else{
						map[tx][ty]=t1;
						map[rob[t1].x][rob[t1].y]=0;
						rob[t1].x=tx;
						rob[t1].y=ty;					
					}
				}
			}
		}
		if (flag==0)
			printf("OK\n");
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_42172261/article/details/89524979