lightoj1197大区间筛素数

Amakusa, the evil spiritual leader has captured the beautiful princess Nakururu. The reason behind this is he had a little problem with Hanzo Hattori, the best ninja and the love of Nakururu. After hearing the news Hanzo got extremely angry. But he is clever and smart, so, he kept himself cool and made a plan to face Amakusa.

Before reaching Amakusa's castle, Hanzo has to pass some territories. The territories are numbered as a, a+1, a+2, a+3 ... b. But not all the territories are safe for Hanzo because there can be other fighters waiting for him. Actually he is not afraid of them, but as he is facing Amakusa, he has to save his stamina as much as possible.

He calculated that the territories which are primes are safe for him. Now given a and b he needs to know how many territories are safe for him. But he is busy with other plans, so he hired you to solve this small problem!

Input

Input starts with an integer T (≤ 200), denoting the number of test cases.

Each case contains a line containing two integers a and b (1 ≤ a ≤ b < 231, b - a ≤ 100000).

Output

For each case, print the case number and the number of safe territories.

Sample Input

3

2 36

3 73

3 11

Sample Output

Case 1: 11

Case 2: 20

Case 3: 4

Note

A number is said to be prime if it is divisible by exactly two different integers. So, first few primes are 2, 3, 5, 7, 11, 13, 17, ...

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define maxn 1000005
#define ll long long
using namespace std;
int p[maxn];
bool vis[maxn];
bool prime[maxn];
int cnt;
int t;
void init()
{
    cnt=0;

    memset(vis,0,sizeof(vis));
    
    for(int i=2;i<maxn;i++)
    {
        if(!vis[i])
            p[cnt++]=i;
        for(int j=0;j<cnt&&i*p[j]<maxn;j++)
        {
            vis[i*p[j]]=1;
            if(i%p[j]==0)
                break;
        }
    }
}
int main()
{
    init();
    scanf("%d",&t);
    int w=0;
    while(t--)
    {w++;
     for(int i=0;i<maxn;i++)
        prime[i]=1;
        ll a,b;
        scanf("%lld%lld",&a,&b);
        ll ans=b-a+1;
        if(a==1)
            ans--;
        for(int i=0;i<cnt&&1LL*p[i]*p[i]<=b;i++)
        {
            for(ll j=a/p[i]*p[i];j<=b;j+=p[i])
                if(j>=a&&j>p[i])
                prime[j-a]=0;
        }
        for(int i=0;i<=b-a;i++)
            if(!prime[i])
                ans--;
           printf("Case %d: %lld\n",w,ans);
    }
    return 0;

}

猜你喜欢

转载自blog.csdn.net/sdauguanweihong/article/details/89810812