Communication System(贪心)

版权声明:转载请注明出处链接 https://blog.csdn.net/qq_43408238/article/details/89526722

Communication System

Description

We have received an order from Pizoor Communications Inc. for a special communication system. The system consists of several devices. For each device, we are free to choose from several manufacturers. Same devices from two manufacturers differ in their maximum bandwidths and prices.
By overall bandwidth (B) we mean the minimum of the bandwidths of the chosen devices in the communication system and the total price (P) is the sum of the prices of all chosen devices. Our goal is to choose a manufacturer for each device to maximize B/P.

Input

The first line of the input file contains a single integer t (1 ≤ t ≤ 10), the number of test cases, followed by the input data for each test case. Each test case starts with a line containing a single integer n (1 ≤ n ≤ 100), the number of devices in the communication system, followed by n lines in the following format: the i-th line (1 ≤ i ≤ n) starts with mi (1 ≤ mi ≤ 100), the number of manufacturers for the i-th device, followed by mi pairs of positive integers in the same line, each indicating the bandwidth and the price of the device respectively, corresponding to a manufacturer.

Output

Your program should produce a single line for each test case containing a single number which is the maximum possible B/P for the test case. Round the numbers in the output to 3 digits after decimal point.

Sample Input

1 3
3 100 25 150 35 80 25
2 120 80 155 40
2 100 100 120 110

Sample Output

0.649

            很久的一道贪心专题中的题目了, 用搜索超时了,不过感觉思路还是不错的

#include<iostream>
#include<vector>
#include<string>
#include<cstring>
#include<cmath>
#include <algorithm>
#include <stdlib.h>
#include <cstdio>
#include<sstream>
#include<cctype>
#include <set>
#include<queue>
#include <map>
#include <iomanip>
#define  INF  0x3f3f3f3f
#define mmt(a,b)  memset(a,b,sizeof(a))
typedef long long ll;
const ll MAX=1000000;
using namespace std;
vector<vector<ll> > B(150);
vector<vector<ll> > P(150);
  ll t,n,m;double Max,Min,sum;
 ll ans[1000];
 double min_(ll a,ll b,ll c)//B是三个B中最小的
 {
     return min(B[1][a],min(B[2][b],B[3][c]));
 }
void dfs(ll step)
{
    if(step==n+1) {
        Min=min_(ans[1],ans[2],ans[3]);
        Max=max(Max,Min*1.0/sum);//记录最大的B/P
        return ;
    }
    ll l=B[step].size();
    for(ll i=0;i<l;++i)
    {
       ans[step]=i;
        sum+=P[step][i];
        dfs(step+1);
        sum-=P[step][i];
    }
}
void init()//清空
{
    for(ll i=1;i<=n+1;i++)
    {
        B[i].erase(B[i].begin(),B[i].end());
         P[i].erase(P[i].begin(),P[i].end());
    }
}
int main()
{

     cin>>t;
    while(t--)
    {

        cin>>n;Min=INF;sum=0; Max=-INF;
         init();
        for(ll i=1;i<=n;++i)
        {
               cin>>m;
            for(ll j=1;j<=m;++j)
           {
               ll b,p;
               cin>>b>>p;B[i].push_back(b);P[i].push_back(p);
           }
        }
        dfs(1);
        cout<<fixed<<setprecision(3)<<Max<<endl;
    }

}

贪心:

详见参考 Communication System(枚举 + 贪心)

#include<iostream>
#include<vector>
#include<string>
#include<cstring>
#include<cmath>
#include <algorithm>
#include <stdlib.h>
#include <cstdio>
#include<sstream>
#include<cctype>
#include <set>
#include<queue>
#include <map>
#define ll long long
#define  INF  0x3f3f3f3f
using namespace std;
set<int> s;//保存所有的可能的带宽
set<int>::iterator it;
int band[105][105],price[105][105],m[105];
int main()
{
    int T,n,i,j;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        s.clear();
        for(i=0;i<n;++i)
        {
            scanf("%d",&m[i]);
            for(j=0;j<m[i];++j)
            {
                scanf("%d%d",&band[i][j],&price[i][j]);
                s.insert(band[i][j]);
            }
        }
        double rata=0;
        for(it=s.begin();it!=s.end();++it)//枚举所有可能的带宽
        {
            int k=*it,sum_price=0;
            for(i=0;i<n;++i)//对于每一个供应商
            {
                int min_price=INF;
                for(j=0;j<m[i];++j)//挑出个供应商中的一件设备
                {
                    if(band[i][j]>=k&&price[i][j]<=min_price)//挑选满足条件的价值最小的
                        min_price=price[i][j];
                }
                  sum_price+=min_price;
            }
            rata=max(rata,k*1.0/sum_price);



        }
        printf("%.3lf\n",rata);


    }
}

猜你喜欢

转载自blog.csdn.net/qq_43408238/article/details/89526722