单链表结点删除 (20分)

本题要求实现两个函数,分别将读入的数据存储为单链表、将链表中所有存储了某给定值的结点删除。链表结点定义如下:

struct ListNode {
int data;
ListNode *next;
};

函数接口定义:
struct ListNode *readlist();
struct ListNode *deletem( struct ListNode *L, int m );

函数readlist从标准输入读入一系列正整数,按照读入顺序建立单链表。当读到−1时表示输入结束,函数应返回指向单链表头结点的指针。

函数deletem将单链表L中所有存储了m的结点删除。返回指向结果链表头结点的指针。

裁判测试程序样例:
#include <stdio.h>
#include <stdlib.h>

struct ListNode {
int data;
struct ListNode *next;
};

struct ListNode *readlist();
struct ListNode *deletem( struct ListNode *L, int m );
void printlist( struct ListNode *L )
{
struct ListNode *p = L;
while § {
printf("%d “, p->data);
p = p->next;
}
printf(”\n");
}

int main()
{
int m;
struct ListNode *L = readlist();
scanf("%d", &m);
L = deletem(L, m);
printlist(L);
return 0;
}

/* 你的代码将被嵌在这里 */

输入样例:
10 11 10 12 10 -1
10

扫描二维码关注公众号,回复: 10019804 查看本文章

输出样例:
11 12
/* 你的代码将被嵌在这里 */

struct ListNode *readlist()
{   struct ListNode  *head=NULL, *p=NULL ,*temp =NULL;
    int x;
    scanf("%d",&x);
    while(x != -1){
        temp = (struct ListNode*)malloc(sizeof(struct ListNode));
        temp->data = x;
        temp->next = NULL;//可略去不写
        if(p==NULL)
            head = p = temp;
        else{
            p->next = temp;
            p = temp;
        }
        scanf("%d",&x);
    }
    return head;
}
struct ListNode *deletem( struct ListNode *L, int m )
{
	struct ListNode *p=NULL,*temp=NULL;
	if(L==NULL)
	{
		return NULL;
	}
	p=L;
	temp=p->next ;
	while(temp)
	{
		if( temp->data ==m )
		{
			p->next =temp->next ;
			free(temp);
			temp=p->next ;
		}
		else 
		{
			p=p->next ;
			temp=p->next ;
		}
	}
	if(L->data ==m )
	{
		L=L->next ;
	}
	return L;
}

发布了36 篇原创文章 · 获赞 1 · 访问量 522

猜你喜欢

转载自blog.csdn.net/weixin_45821690/article/details/104526407