习题7(hdu). 水果店(map)STL

 http://acm.hdu.edu.cn/showproblem.php?pid=1263

水果

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13620    Accepted Submission(s): 5353


 

Problem Description

夏天来了~~好开心啊,呵呵,好多好多水果~~
Joe经营着一个不大的水果店.他认为生存之道就是经营最受顾客欢迎的水果.现在他想要一份水果销售情况的明细表,这样Joe就可以很容易掌握所有水果的销售情况了.

 

Input

第一行正整数N(0<N<=10)表示有N组测试数据.
每组测试数据的第一行是一个整数M(0<M<=100),表示工有M次成功的交易.其后有M行数据,每行表示一次交易,由水果名称(小写字母组成,长度不超过80),水果产地(小写字母组成,长度不超过80)和交易的水果数目(正整数,不超过100)组成.

 

Output

对于每一组测试数据,请你输出一份排版格式正确(请分析样本输出)的水果销售情况明细表.这份明细表包括所有水果的产地,名称和销售数目的信息.水果先按产地分类,产地按字母顺序排列;同一产地的水果按照名称排序,名称按字母顺序排序.
两组测试数据之间有一个空行.最后一组测试数据之后没有空行.

 

Sample Input

 

1 5 apple shandong 3 pineapple guangdong 1 sugarcane guangdong 1 pineapple guangdong 3 pineapple guangdong 1

 

Sample Output

 

guangdong |----pineapple(5) |----sugarcane(1) shandong |----apple(3)

#include <bits/stdc++.h>
using namespace std;

map<string,map<string,int> > mp;
int main()
{
	int n;
	cin>>n;
	string s1,s2;
	int d;
	for(int i=0;i<n;++i)
	{
		cin>>s1>>s2>>d;
		mp[s2][s1]+=d;
	}
	for(map<string,map<string,int> >::iterator it1=mp.begin();it1!=mp.end();++it1)
	{
		cout<<(it1->first)<<endl;
		for(map<string,int>::iterator it2=(it1->second).begin();it2!=(it1->second).end();++it2)
		cout<<"   I----"<<(it2->first)<<"("<<(it2->second)<<")"<<endl;
	}
 	return 0;
} 

猜你喜欢

转载自blog.csdn.net/intmain_S/article/details/89673425