eigrp

向eigrp注入默认路由

1,从发布静态路由

configure terminal

ip route 0.0.0.0 0.0.0.0 serial 0/0

router eigrp 100
no auto-summary
network 1.1.1.1 0.0.0.255
redistributestatic

2,宣告默认路由

ip route 0.0.0.0 0.0.0.0 serial 0/0

router eigrp 100
no auto-summary
network 1.1.1.1 0.0.0.255
network 0.0.0.0

3,ip default-network

router eigrp 100
network 1.1.1.1 0.0.0.255
network 12.0.0.0

ip default-network 12.0.0.0
ip route 12.0.0.0 255.0.0.0 null0
##########################################################

路由汇总

主类路由边界(主类或主类内部子网)会自动汇总
对路由的出接口做汇总
ip summary-address eigrp 100 199.8.0 255.255.252.0

##########################################################

eigrp 重置路由关系实验acl使用

access-list 100 deny eigrp any any
access-list 100 permit any any
interface serial 0/0
ip access-list 100 in

debug eigrp packets event
(重置邻居关系1 hello包未应答 2 16次retry超时 3 query3分钟超时stuck to active)
配置stuck to active

timers active-time 3


##########################################################

扩散更新算法(dual算法)
FD AD success feasible-success
router eigrp 100
maximum-path 6
等价负载均衡metric值相等
非等价负载均衡 (variance 2)
success’s FD * veriance > Feasible success’ FD

router eigrp 100
variance 2
int e 1/0
delay 10000 (实际是10000*10)
##########################################################

广域网wan链路

int s 0/0
bandwidth 10
ip bandwidth-percent eigrp 100 200
###########################################################

1,限制查询包的范围
ip summary-address eigrp 100 10.0.0.0 255.0.0.0
2,eigrp stub末梢
router eigrp 100
eigrp stub ?

###########################################################
eigrp认证

conf ter
key chain davy
key 1
key-string davy123
exit
interface s 0/0
ip authentication key-chain eigrp 100 davy
ip authentication mode eigrp 100 MD5
no shutdow
exit
##########################################################

优化

1,被动接口
router eigrp 100
passive-interface loopback 0(不收发eigrp报文任然有loopback的路由)
2,偏移列表(修改某路由的mectric)
access-list 1 permit 1.1.1.0
router eigrp 100
offset-list 1 in 4serial 0/0


############################################################################


###################
启动eigrp协议进程##
###################

router eigrp autonomous-system
network network-number{wildcard-mask}

router eigrp autonomous-system
passive-interface {type number}default


################################
在出口上汇总本地宣告的路由明细##
################################
router eigrp 100
no auto-summary
interface e0
ip summary-address eigrp 100 172.16.0.0 255.255.0.0

################################
eigrp的默认路由  主类路由     ##
################################

ip default-network network-number

##########
负载均衡##
##########

##############
等价负载均衡##
matric值相等##
默认支持4条 ##
最大支持16条##
##############

maximum-paths maximum-path

################
非等价负载均衡##
在度量值不等的##
路径上负载均衡##
################

variance multipler

#multipler(1-128倍数)
#AD<FD(min)
#FD<=FD(min) X multipler

#######################
eigrp的认证(R1,R2)##
#######################
R1

conf ter
key chain davy
key 1
key-string davy123
exit
interface s 0/0
ip authentication key-chain eigrp 1 davy
ip authentication mode eigrp 1 MD5
no shutdow
exit
#############################################
R2

conf ter
key chain davy
key 1
key-string davy123
exit
interface s 0/0
ip authentication key-chain eigrp 1 davy
ip authentication mode eigrp 1 MD5
no shutdow
exit


################################
优化eigrp                     ##
避免sia(sink in active)     ##
sia-查询、sia-应答            ##
在active-timers一半时发       ##
################################
模拟sia
 
active timer 默认3m改为1m
router eigrp 1
timers active-time 1

开启debug
debug eigrp pi

定义acl 只允许hello包 接口上开启acl
access-list 100 permit eigrp any host 244.0.0.10
interface s 0/0
ip access-group 100 in

停止 lo0
interface lo0
shutdown

################################
限制查询范围

router eigrp 1
eigrp stub ??


配置 RA2:
Router>enable
Router#configure terminal
Router(config)#hostname ra2
ra2(config)#enable secret cisco
ra2(config)#no ip domain-lookup
ra2(config)#line console 0
ra2(config-line)#logging synchronous
ra2(config-line)#exit

ra2(config)#interface serial 0
ra2(config-if)# no shutdown
ra2(config-if)#ip address 12.1.1.2 255.255.255.0
ra2(config-if)#ip summary-address eigrp 1 172.16.0.0 255.255.252.0
ra2(config-if)#interface serial 1
ra2(config-if)#no shutdown
ra2(config-if)#ip address 23.1.1.2 255.255.255.0
ra2(config-if)#ip summary-address eigrp 1 172.16.0.0 255.255.252.0
ra2(config-if)#interface ethernet 0
ra2(config-if)#no shutdown
ra2(config-if)#ip address 22.1.1.2 255.255.255.0
ra2(config-if)#no keepalive
ra2 (config-if)#exit

ra2(config)#router eigrp 1
ra2(config-router)#network 11.0.0.0
ra2(config-router)#network 23.0.0.0
ra2(config-router)#network 22.0.0.0


 


 


 

猜你喜欢

转载自davidlee1986.iteye.com/blog/1919381
今日推荐