poj-2479

Maximum sum
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 42649   Accepted: 13275

Description

Given a set of n integers: A={a1, a2,..., an}, we define a function d(A) as below:
Your task is to calculate d(A).

Input

The input consists of T(<=30) test cases. The number of test cases (T) is given in the first line of the input. 
Each test case contains two lines. The first line is an integer n(2<=n<=50000). The second line contains n integers: a1, a2, ..., an. (|ai| <= 10000).There is an empty line after each case.

Output

Print exactly one line for each test case. The line should contain the integer d(A).

Sample Input

1

10
1 -1 2 2 3 -3 4 -4 5 -5

Sample Output

13

Hint

In the sample, we choose {2,2,3,-3,4} and {5}, then we can get the answer. 

Huge input,scanf is recommended.

/*动态规划
从前向后遍历一次,找到以i结束的最大和
从后向前遍历一次,找到以i开始的最大和
遍历一遍找到两段的最大和*/
#include <iostream>
#include <cstdio>
#include <cmath>
using namespace std;
#include<stdio.h>
#define MAX 200000
#define max(A,B)((A)>=(B)?(A):(B))
const int inf=-999999;
int l[MAX],r[MAX],a[MAX],dp1[MAX],dp2[MAX];
int main()
{
 int i,t,n,maxsum;
    scanf("%d\n",&t);//案例组
    while(t--){
        scanf("%d",&n);//每组案例数
        for(i=1;i<=n;i++)
            scanf("%d",&a[i]);//把案例的数都存放到数组里
  dp1[1]=a[1];
  dp2[n]=a[n];
  l[1]=a[1];
  r[n]=a[n];
  for(i=2;i<=n;i++)//从左遍历,找最大和
  {
      dp1[i]=max(dp1[i-1]+a[i],a[i]);
      l[i]=max(dp1[i],l[i-1]);
      }
  for(i=n-1;i>=1;i--)//从右遍历,找最大和
  {
      dp2[i]=max(dp2[i+1]+a[i],a[i]);
      r[i]=max(dp2[i],r[i+1]);
      }
  maxsum=inf;
  for(i=1;i<=n-1;i++){//找这两段的最大和
      maxsum=max(maxsum,l[i]+r[i+1]);
  }
  printf("%d\n",maxsum);
}
 return 0;
}

猜你喜欢

转载自blog.csdn.net/fenger_c/article/details/79759197
POJ