po'j2559 Largest Rectangle in a Histogram 单调栈(递增)

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 29498   Accepted: 9539

Description

A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles:

Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.

Input

The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1<=n<=100000. Then follow n integers h1,...,hn, where 0<=hi<=1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.

Output

For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.

Sample Input

7 2 1 4 5 1 3 3
4 1000 1000 1000 1000
0

Sample Output

8
4000

Hint

Huge input, scanf is recommended.
 
题意:有N个矩形,宽度都为1,给出N个矩形的高度,求由这N个矩形组成的图形包含的最大的矩形面积
 
//单调递增栈
#include<iostream>
#define ll long long
#include<stack>
using namespace std;
stack<ll>p;     //栈里面存的是下标
ll a[100005];
ll n,s,top;
int main()
{
    while(~scanf("%lld",&n))
    {
        if(n==0)
            break;
        while(!p.empty())
            p.pop();
        for(int i=0;i<n;i++)
            scanf("%lld",&a[i]);
        a[n]=-1;//为找比a[n-1]小的数准备,因为是递增栈,将a[n]设为最小值
        s=0;
        for(int i=0;i<=n;i++)
        {
            if(p.empty()||a[i]>=a[p.top()])//看题目要求是否要严格单调递增,这里只要求递增
                p.push(i);
            else
            {
                while(!p.empty()&&a[i]<a[p.top()])//找到第一个小于栈顶元素的数的下标
                {
                    top=p.top();
                    p.pop();//只在在出栈的过程中以a[top]为最小值更新面积s
                    if(s<(i-top)*a[top])
                        s=(i-top)*a[top];
                }
                p.push(top);//只将延伸到最左端的元素入栈,并且以最左端的元素的!坐标!为起点,找下一个比a[i]大的最长增区间
                a[top]=a[i];//修改该位置的值为a[i]
                
            }
        }
        printf("%lld\n",s);
    }
    return 0;

}

猜你喜欢

转载自www.cnblogs.com/-citywall123/p/10770468.html
今日推荐