Largest Rectangle in a Histogram(单调栈)

A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles: 
 
Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.

Input

The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1 <= n <= 100000. Then follow n integers h1, ..., hn, where 0 <= hi <= 1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.

Output

For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.

Sample Input

7 2 1 4 5 1 3 3
4 1000 1000 1000 1000
0

Sample Output

8
4000

题目大意:给你一个直方图,告诉你各个条形矩形的高度,求基线对齐构成的矩形中面积

最大的矩形的面积。

题目分析:

对于第i个 求它向右能最大延展到编号几,再求它向左能最大延展到编号几。s=r-l+1*a[i];

枚举每个点,维护最大值。

代码:

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include<stack>
typedef long long ll;
using namespace std;
ll a[100005],l[100005],r[100005];
ll n;
stack<ll>s;
int main()
{
	while(cin>>n&&n){
		for(ll i=1;i<=n;i++)cin>>a[i];
		a[0]=a[n+1]=-1;
		for(ll i=1;i<=n+1;i++){
			while(!s.empty()&&a[i]<a[s.top()]){
				 r[s.top()]=i;
				 s.pop();
			}
			s.push(i);
		}
		while(!s.empty())s.pop();
		for(ll i=n;i>=0;i--){
			while(!s.empty()&&a[i]<a[s.top()]){
				l[s.top()]=i;
				s.pop();
			}
			s.push(i);
		}
		while(!s.empty())s.pop();
		ll ans=0;
		for(ll i=1;i<=n;i++){
			ll R=r[i]-1,L=l[i]+1;
			ans=max(ans,a[i]*(R-L+1));
		}
		printf("%lld\n",ans);
	}
		
}

猜你喜欢

转载自blog.csdn.net/qq_43490894/article/details/87888238
今日推荐