Find Coins (25)

版权声明:本文章由BlackCarDriver原创,欢迎评论和转载 https://blog.csdn.net/BlackCarDriver/article/details/89135893

链接:https://www.nowcoder.com/pat/5/problem/4087
题目:
Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she could only use exactly two coins to pay the exact amount. Since she has as many as 105 coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find two coins to pay for it.
输入描述:
Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (<=10^5, the total number of coins) and M(<=103, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers no more than 500. All the numbers in a line are separated by a space.
输出描述:
For each test case, print in one line the two face values V1 and V2 (separated by a space) such that V1 + V2 = M and V1 <= V2. If such a solution is not unique, output the one with the smallest V1. If there is no solution, output “No Solution” instead.
示例输入
8 15
1 2 8 7 2 4 11 15
示例输出
4 11


大意描述:
给你一堆硬币和一个数字,你需要从这堆硬币中找出两个硬币组成这个面值。按照又小到大的顺序输出这两个硬币。

分析
非常简单的一道题。看题时注意题目没直接讲明相同面值的硬币可能有两个以上,但是
“ V1 <= V2. ” 说明了这一点。因此要注意两个硬币面值相同的情况。另外,由于是由小到大找第一个硬币,所以遍历一半即可。

思路
用一个数组来保存每个面值的硬币数量,直接遍历就能达到硬币面值保持升序的效果。
简单模拟。

MyCode

 #include<iostream>
#include<stdio.h>
using namespace std;
const int maxn = 100009;
int coin[maxn];	//coin[i] mean the number of coin with value i
int cnum, amount;
int main(){
	//get input data
	cin >> cnum >> amount;
	for (int i = 0; i < cnum; i++){
		int value;
		scanf("%d", &value);
		coin[value]++;
	}
	//find the answer
	int coin1 = -1; //the first coin value, -1 mean no answer
	for (int i = 1; i < maxn; i++){	//i mean value, coin[i] mean munber of coin with value i
		if (coin[i] == 0) continue;	//not have it value
		int res = amount - i;
		if (i > res) break;	//already checked
		if (res == i){	//need two same vlue coins
			if (coin[res]  < 2 ) continue;
			coin1 = i;
			break;
		}
		if (coin[res] > 0){//need two different coins
			coin1 = i;
			break;
		}
	}
	if (coin1 == -1) cout << "No Solution" << endl;
	else cout << coin1 << " " << amount - coin1 << endl;
}

猜你喜欢

转载自blog.csdn.net/BlackCarDriver/article/details/89135893