1048 Find Coins (25)(25 point(s))

版权声明:本文为博主原创文章,需表明来源,方可随意转载。 https://blog.csdn.net/qq_36589706/article/details/81590002

Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she could only use exactly two coins to pay the exact amount. Since she has as many as 10^5^ coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find two coins to pay for it.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (<=10^5^, the total number of coins) and M(<=10^3^, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers no more than 500. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the two face values V~1~and V~2~(separated by a space) such that V~1~ + V~2~ = M and V~1~ <= V~2~. If such a solution is not unique, output the one with the smallest V~1~. If there is no solution, output "No Solution" instead.

Sample Input 1:

8 15
1 2 8 7 2 4 11 15

Sample Output 1:

4 11

Sample Input 2:

7 14
1 8 7 2 4 11 15

Sample Output 2:

No Solution

解法1:hash表 

#include <cstdio>
#include<algorithm>
using namespace std;
const int maxn=100010;
int main(){
	int n, m, a, hashTable[maxn]={0}, flag=0;
	scanf("%d%d", &n, &m);
	for(int i=0; i<n; i++){
		scanf("%d", &a);
		hashTable[a]++;
	} 
	for(int i=1; i<m; i++){  //m 用得很妙
		if(hashTable[i]!=0&&hashTable[m-i]!=0){
			if(i==m-i&&hashTable[i]<=1){
				continue;
			}
			printf("%d %d", i, m-i);
			flag=1;
			break;
		}
	}
	if(flag==0)printf("No Solution");
	return 0;
}

解法2: 二分法

#include<cstdio>
#include<algorithm>
using namespace std;
const int maxn=100010;
int arr[maxn];
int upper_bound( int left, int right, int num){
	int mid;
	while(left<=right){
		mid=(right+left)/2;
		if(arr[mid]==num){
			return mid;
		}else if(arr[mid]>num){
			right=mid-1;
		}else if(arr[mid]<num){
			left=mid+1;
		}
	}
	return -1;
}
int main(){
	int n, num; 
	scanf("%d%d", &n, &num);
	for(int i=0; i<n; i++){
		scanf("%d", &arr[i]);
	}
	sort(arr, arr+n);
	int i=0;
	for(; i<n; i++){
		int pos=upper_bound(i, n-1, num-arr[i]);
		if(pos>0&&pos!=i){ //注意i、pose重复
			printf("%d %d", arr[i], arr[pos]);
			break;
		}
	}
	if(i==n)printf("No Solution");
    return 0;
}

解法3:two pointers

#include<cstdio>
#include<algorithm>
using namespace std;
const int maxn=100010;
int arr[maxn];
int main(){
	int n, num; 
	scanf("%d%d", &n, &num);
	for(int i=0; i<n; i++){
		scanf("%d", &arr[i]);
	}
	sort(arr, arr+n);
	int i=0, j=n-1;
	while(i<j){
		if(arr[i]+arr[j]>num){
			j--;
		}else if(arr[i]+arr[j]<num){
			i++;
		}else if(arr[i]+arr[j]==num){
			printf("%d %d",arr[i], arr[j]);
			break;
		}
	}
	if(i==j)printf("No Solution");
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_36589706/article/details/81590002