hdu1560DNA sequence(bfs)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/IDrandom/article/details/87939264

DNA sequence
Time Limit: 15000/5000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4685 Accepted Submission(s): 2241

Problem Description
The twenty-first century is a biology-technology developing century. We know that a gene is made of DNA. The nucleotide bases from which DNA is built are A(adenine), C(cytosine), G(guanine), and T(thymine). Finding the longest common subsequence between DNA/Protein sequences is one of the basic problems in modern computational molecular biology. But this problem is a little different. Given several DNA sequences, you are asked to make a shortest sequence from them so that each of the given sequence is the subsequence of it.

For example, given “ACGT”,“ATGC”,“CGTT” and “CAGT”, you can make a sequence in the following way. It is the shortest but may be not the only one.

Input
The first line is the test case number t. Then t test cases follow. In each case, the first line is an integer n ( 1<=n<=8 ) represents number of the DNA sequences. The following k lines contain the k sequences, one per line. Assuming that the length of any sequence is between 1 and 5.

Output
For each test case, print a line containing the length of the shortest sequence that can be made from these sequences.

Sample Input
1
4
ACGT
ATGC
CGTT
CAGT

Sample Output
8

暴力

#include<bits/stdc++.h>
using namespace std;
char str[10][10];
bool vis[6][6][6][6][6][6][6][6];
int l[9],n;
char di[5]="AGCT";
struct node{
    int p[9];
    int d;
    node(){memset(p,0,sizeof p);d=0;}
};
bool* getvis(node &p){
    return &vis[p.p[1]][p.p[2]][p.p[3]][p.p[4]][p.p[5]][p.p[6]][p.p[7]][p.p[8]];
}
int check(node &p){
    for(int i=1;i<=8;i++)if(p.p[i]!=l[i])return 0;
    return 1;
}
int bfs(){
    memset(vis,0,sizeof vis);
    queue<node>mq;
    node st;st.d=0;
    for(int i=1;i<=n;i++)st.p[i]=0;
    bool *pst=getvis(st);
    *pst=true;
    mq.push(st);
    while(!mq.empty()){
        node nw=mq.front();
        mq.pop();
        if(check(nw))return nw.d;
        for(int i=0;i<4;i++){
            int f=0;
            node nxt=nw;
            for(int j=1;j<=n;j++){
                if(di[i]==str[j][nw.p[j]]){
                    nxt.p[j]++;
                    f=1;
                }
            }
            if(f){
                nxt.d++;
                bool *nxtp=getvis(nxt);
                if(*nxtp)continue;
                *nxtp=true;
                mq.push(nxt);
            }
        }
    }
}
int main(){
    ios::sync_with_stdio(false);
    cin.tie(0);
    int t;
    cin>>t;
    while(t--){
        cin>>n;
        memset(l,0,sizeof l);
        memset(str,0,sizeof str);
        for(int i=1;i<=n;i++){
            cin>>str[i];
            l[i]=strlen(str[i]);
        }
        cout<<bfs()<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/IDrandom/article/details/87939264