滑雪问题, 记忆化搜索

题目:Michael喜欢滑雪百这并不奇怪, 因为滑雪的确很刺激。可是为了获得速度,滑的区域必须向下倾斜,而且当你滑到坡底,你不得不再次走上坡或者等待升降机来载你。Michael想知道载一个区域中最长底滑坡。区域由一个二维数组给出。数组的每个数字代表点的高度。下面是一个例子

1 2 3 4 5

16 17 18 19 6

15 24 25 20 7

14 23 22 21 8

13 12 11 10 9

一个人可以从某个点滑向上下左右相邻四个点之一,当且仅当高度减小。在上面的例子中,一条可滑行的滑坡为24-17-16-1。当然25-24-23-…-3-2-1更长。事实上,这是最长的一条。

Input

输入的第一行表示区域的行数R和列数C(1 <= R,C <= 100)。下面是R行,每行有C个整数,代表高度h,0<=h<=10000。

Output

输出最长区域的长度。

Sample Input

5 5

1 2 3 4 5

16 17 18 19 6

15 24 25 20 7

14 23 22 21 8

13 12 11 10 9

Sample Output

25

思路, 每一个位置向四个方向进行最大长度的搜索, 用num数组保存每一个位置的结果, 实现记忆化搜索。

#include<iostream>
#include<cstdio>
#include<memory.h>
using namespace std;

int net[4][2] = {{1, 0}, {-1, 0}, {0, 1}, {0, -1}};
int map[110][110];
int num[110][110];
int n, m;
int solve(int a, int b)
{
	if(num[a][b]) return num[a][b];
	
	int mm = 1;
	for(int i = 0; i < 4; i++)		//某一个位置最大长度为, 
											//这一个位置可以到达的所有位置中的最大长度+1
	{
		int na = net[i][0] + a;
		int nb = net[i][1] + b;
		if(na >= 0 && na < n && nb >= 0 && nb < m && map[a][b] > map[na][nb])
		mm = max(solve(na, nb) + 1, mm);
	}
	
	return num[a][b] = mm;
}
int main()
{

	cin >> n >>m;
	for(int i = 0; i < n; i++)
	for(int j = 0; j < m; j++)
	cin >> map[i][j];
	
	int mm = -1;
	for(int i = 0; i < n; i++)
	for(int j = 0; j < m; j++)
		mm = max(mm, solve(i, j));
	cout << mm;
} 

猜你喜欢

转载自blog.csdn.net/qq_40212930/article/details/88977920