Out of Hay(POJ-2395)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/u011815404/article/details/89383158

Problem Description

The cows have run out of hay, a horrible event that must be remedied immediately. Bessie intends to visit the other farms to survey their hay situation. There are N (2 <= N <= 2,000) farms (numbered 1..N); Bessie starts at Farm 1. She'll traverse some or all of the M (1 <= M <= 10,000) two-way roads whose length does not exceed 1,000,000,000 that connect the farms. Some farms may be multiply connected with different length roads. All farms are connected one way or another to Farm 1. 

Bessie is trying to decide how large a waterskin she will need. She knows that she needs one ounce of water for each unit of length of a road. Since she can get more water at each farm, she's only concerned about the length of the longest road. Of course, she plans her route between farms such that she minimizes the amount of water she must carry. 

Help Bessie know the largest amount of water she will ever have to carry: what is the length of longest road she'll have to travel between any two farms, presuming she chooses routes that minimize that number? This means, of course, that she might backtrack over a road in order to minimize the length of the longest road she'll have to traverse.

Input

* Line 1: Two space-separated integers, N and M. 

* Lines 2..1+M: Line i+1 contains three space-separated integers, A_i, B_i, and L_i, describing a road from A_i to B_i of length L_i.

Output

* Line 1: A single integer that is the length of the longest road required to be traversed.

Sample Input

3 3
1 2 23
2 3 1000
1 3 43

Sample Output

43

题意:n 个点 m 条边,从 1 到 n 编号,现在要从 1 号出发到其他所有点,每到达一个点可以进行补给,现要使走过的总路径长度最小,问途中最多要携带的补给重量

思路:实质就是要求最小生成树中的最长边,即求图的最小瓶颈生成树,使用 Kruskal 算法即可解决

Source Program

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<string>
#include<cstring>
#include<cmath>
#include<ctime>
#include<algorithm>
#include<utility>
#include<stack>
#include<queue>
#include<vector>
#include<set>
#include<map>
#define EPS 1e-9
#define PI acos(-1.0)
#define INF 0x3f3f3f3f
#define LL long long
const int MOD = 1E9+7;
const int N = 100000+5;
const int dx[] = {-1,1,0,0};
const int dy[] = {0,0,-1,1};
using namespace std;
struct Edge{
    int u,v,w;
    bool operator <(Edge K)const{
        return w<K.w;
    }
}edge[N];
int n,m;
int father[N],res;
int mst=0;
int Find(int x){
    if(father[x]==x)
        return x;
    return father[x]=Find(father[x]);
}
void kruskal(){
    for(int i=1;i<=n;++i)
      father[i]=i;
    sort(edge+1,edge+m+1);
    for(int i=1;i<=m;++i){
        int f1=Find(edge[i].u);
        int f2=Find(edge[i].v);
        if(f1==f2)
            continue;
        father[f2]=f1;

        mst++;
        if(mst==n-1){
            res=edge[i].w;
            return;
        }
    }
}
int main(){
    scanf("%d%d",&n,&m);
    for(int i=1;i<=m;++i)
      scanf("%d%d%d",&edge[i].u,&edge[i].v,&edge[i].w);
    kruskal();
    printf("%d\n",res);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/u011815404/article/details/89383158