hdu6438(2018中国大学生程序设计竞赛 - 网络选拔赛)(优先队列+贪心)

The Power Cube is used as a stash of Exotic Power. There are n cities numbered 1,2,…,n where allowed to trade it. The trading price of the Power Cube in the i-th city is ai dollars per cube. Noswal is a foxy businessman and wants to quietly make a fortune by buying and reselling Power Cubes. To avoid being discovered by the police, Noswal will go to the i-th city and choose exactly one of the following three options on the i-th day:

1. spend ai dollars to buy a Power Cube
2. resell a Power Cube and get ai dollars if he has at least one Power Cube
3. do nothing

Obviously, Noswal can own more than one Power Cubes at the same time. After going to the n cities, he will go back home and stay away from the cops. He wants to know the maximum profit he can earn. In the meanwhile, to lower the risks, he wants to minimize the times of trading (include buy and sell) to get the maximum profit. Noswal is a foxy and successful businessman so you can assume that he has infinity money at the beginning.

Input

There are multiple test cases. The first line of input contains a positive integer T (T≤250), indicating the number of test cases. For each test case:
The first line has an integer n. (1≤n≤105)
The second line has n integers a1,a2,…,an where ai means the trading price (buy or sell) of the Power Cube in the i-th city. (1≤ai≤109)
It is guaranteed that the sum of all n is no more than 5×105.

Output

For each case, print one line with two integers —— the maximum profit and the minimum times of trading to get the maximum profit.

Sample Input

3 4 1 2 10 9 5 9 5 9 10 5 2 2 1

Sample Output

 

16 4 5 2 0 0

Hint

In the first case, he will buy in 1, 2 and resell in 3, 4. profit = - 1 - 2 + 10 + 9 = 16 In the second case, he will buy in 2 and resell in 4. profit = - 5 + 10 = 5 In the third case, he will do nothing and earn nothing. profit = 0

题意:有n个城市,第i天你会达到第i个城市,在第i个城市中,你可以用ai元购买一个物品,或者用ai元卖掉一个物品,你可以同时保存多个物品。最开始你身上没有物品,有无限的金钱,现在要求你从城市1走到城市n,问你最大的收益是多少。

#include <iostream>
#include<stdio.h>
#include<math.h>
#include<queue>
#include<map>
#include <string.h>
using namespace std;
#define ll long long
priority_queue<ll, vector<ll>, greater<ll> >q;
map<int,int>mp;
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        scanf("%d",&n);
        ll sum=0,cnt=0;
        while(!q.empty())
            q.pop();
        mp.clear();
        for(int i=1; i<=n; i++)
        {
            int x;
            scanf("%d",&x);
            if(!q.empty()&&q.top()<x)
            {
                int u=q.top();
                q.pop();
                cnt++;
                q.push(x);
                sum+=x-u;
                if(mp[u])
                {
                    mp[u]--;
                    cnt--;
                }
                mp[x]++;
            }
            q.push(x);
        }
        printf("%lld %lld\n",sum,cnt*2);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/Kuguotao/article/details/89096246
今日推荐