HDU - 3966 Aragorn's Story(树链剖分,树状数组模式)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/chenshibo17/article/details/87366575

Our protagonist is the handsome human prince Aragorn comes from The Lord of the Rings. One day Aragorn finds a lot of enemies who want to invade his kingdom. As Aragorn knows, the enemy has N camps out of his kingdom and M edges connect them. It is guaranteed that for any two camps, there is one and only one path connect them. At first Aragorn know the number of enemies in every camp. But the enemy is cunning , they will increase or decrease the number of soldiers in camps. Every time the enemy change the number of soldiers, they will set two camps C1 and C2. Then, for C1, C2 and all camps on the path from C1 to C2, they will increase or decrease K soldiers to these camps. Now Aragorn wants to know the number of soldiers in some particular camps real-time.

Input

Multiple test cases, process to the end of input. 

For each case, The first line contains three integers N, M, P which means there will be N(1 ≤ N ≤ 50000) camps, M(M = N-1) edges and P(1 ≤ P ≤ 100000) operations. The number of camps starts from 1. 

The next line contains N integers A1, A2, ...AN(0 ≤ Ai ≤ 1000), means at first in camp-i has Ai enemies. 

The next M lines contains two integers u and v for each, denotes that there is an edge connects camp-u and camp-v. 

The next P lines will start with a capital letter 'I', 'D' or 'Q' for each line. 

'I', followed by three integers C1, C2 and K( 0≤K≤1000), which means for camp C1, C2 and all camps on the path from C1 to C2, increase K soldiers to these camps. 

'D', followed by three integers C1, C2 and K( 0≤K≤1000), which means for camp C1, C2 and all camps on the path from C1 to C2, decrease K soldiers to these camps. 

'Q', followed by one integer C, which is a query and means Aragorn wants to know the number of enemies in camp C at that time.

Output

For each query, you need to output the actually number of enemies in the specified camp.

Sample Input

3 2 5
1 2 3
2 1
2 3
I 1 3 5
Q 2
D 1 2 2
Q 1 
Q 3

Sample Output

7
4
8

        
  

Hint

1.The number of enemies may be negative.

2.Huge input, be careful. 
#include<bits/stdc++.h>
using namespace std;
const int maxn = 50010;
struct edge {
	int v, ne;
}ed[maxn * 2];
int head[maxn], cnt, n;
int fa[maxn], son[maxn], num[maxn], deep[maxn];
int p[maxn], fp[maxn], top[maxn];
int pos;
void init() {
	cnt = 0;
	memset(head, -1, sizeof head);
	pos = 1;//emmmm树状数组从1开始
	memset(son, -1, sizeof son);
}
void addedge(int u, int v) {
	ed[cnt].v = v; 
	ed[cnt].ne = head[u]; 
	head[u] = cnt++;
}
void dfs1(int u, int pre,int d) {
	deep[u] = d;
	fa[u] = pre;
	num[u] = 1;
	for (int i = head[u]; ~i; i = ed[i].ne) {
		int v = ed[i].v;
		if (v == pre)continue;
		dfs1(v, u, d + 1);
		num[u] += num[v];
		if (son[u] == -1 || num[v] > num[son[u]])
			son[u] = v;
	}
}
void getpos(int u, int sp) {
	top[u] = sp;
	p[u] = pos++;
	fp[p[u]] = u;
	if (son[u] == -1)return;
	getpos(son[u], sp);
	for (int i = head[u]; ~i; i = ed[i].ne) {
		int v = ed[i].v;
		if (v != son[u] && v != fa[u]) {
			getpos(v, v);
		}
	}
}
int c[maxn];
int lowbit(int x) {
	return x&(-x);
}
int sum(int i) {
	int sum = 0;
	while (i > 0) {
		sum += c[i];
		i -= lowbit(i);
	}
	return sum;
}
void add(int i, int v) {
	while (i <= n) {
		c[i] += v;
		i += lowbit(i);
	}
}
void Change(int u, int v, int val) {
	int f1 = top[u], f2 = top[v];
	int tmp = 0;
	while (f1 != f2) {
		if (deep[f1] < deep[f2]) {
			swap(f1, f2);
			swap(u, v);
		}
		add(p[f1], val);
		add(p[u] + 1, -val);
		u = fa[f1];
		f1 = top[u];
	}
	if (deep[u] > deep[v])swap(u, v);
	add(p[u], val);
	add(p[v] + 1, -val);
}
int a[maxn];
int main() {
	ios::sync_with_stdio(0);
	int m, k;
	while (cin >> n >> m >> k) {
		init();
		for (int i = 1; i <= n; i++) {
			cin >> a[i];
		}
		for (int i = 0; i < m; i++) {
			int a, b;
			cin >> a >> b;
			addedge(a, b); addedge(b, a);
		}
		dfs1(1, 0, 0);	
		getpos(1, 1);
		memset(c, 0, sizeof c);
		for (int i = 1; i <= n; i++) {
			add(p[i], a[i]);
			add(p[i] + 1, -a[i]);
		}
		while (k--) {
			char q; cin >> q;
			int a, b, c;
			if (q == 'Q') {
				cin >> a;
				cout << sum(p[a]) << "\n";
			}
			else if (q == 'I') {
				cin >> a >> b >> c;
				Change(a, b, c);
			}
			else {
				cin >> a >> b >> c;
				Change(a, b, -c);
			}
		}
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/chenshibo17/article/details/87366575