【栈】POJ1363-Rails

版权声明:本文为博主原创文章,转载请留言通知。 https://blog.csdn.net/silent0001/article/details/52304125

      这次是栈的东西。所谓栈,就是相当于装羽毛球的桶一样的,最后装入的羽毛球(元素)是会被最先拿出来的。而它的用法。。。这里不详述了,相当于一个容器一样,要包含<stack>的头文件,而常用的函数有这些:

                                                      1.入栈:如s.push(x);

                                                      2.出栈:如 s.pop().注意:出栈操作只是删除栈顶的元素,并不返回该元素。

                                                      3.访问栈顶:如s.top(); 

                                                      4.判断栈空:如s.empty().当栈空时返回true。

                                                      5.访问栈中的元素个数,如s.size();


这道题正是对栈的模拟,上题吧:

【题目】

Rails
Time Limit: 1000MS   Memory Limit: 10000K
     

Description

There is a famous railway station in PopPush City. Country there is incredibly hilly. The station was built in last century. Unfortunately, funds were extremely limited that time. It was possible to establish only a surface track. Moreover, it turned out that the station could be only a dead-end one (see picture) and due to lack of available space it could have only one track. 

The local tradition is that every train arriving from the direction A continues in the direction B with coaches reorganized in some way. Assume that the train arriving from the direction A has N <= 1000 coaches numbered in increasing order 1, 2, ..., N. The chief for train reorganizations must know whether it is possible to marshal coaches continuing in the direction B so that their order will be a1, a2, ..., aN. Help him and write a program that decides whether it is possible to get the required order of coaches. You can assume that single coaches can be disconnected from the train before they enter the station and that they can move themselves until they are on the track in the direction B. You can also suppose that at any time there can be located as many coaches as necessary in the station. But once a coach has entered the station it cannot return to the track in the direction A and also once it has left the station in the direction B it cannot return back to the station. 

Input

The input consists of blocks of lines. Each block except the last describes one train and possibly more requirements for its reorganization. In the first line of the block there is the integer N described above. In each of the next lines of the block there is a permutation of 1, 2, ..., N. The last line of the block contains just 0. 

The last block consists of just one line containing 0.

Output

The output contains the lines corresponding to the lines with permutations in the input. A line of the output contains Yes if it is possible to marshal the coaches in the order required on the corresponding line of the input. Otherwise it contains No. In addition, there is one empty line after the lines corresponding to one block of the input. There is no line in the output corresponding to the last ``null'' block of the input.

Sample Input

5
1 2 3 4 5
5 4 1 2 3
0
6
6 5 4 3 2 1
0
0

Sample Output

Yes
No

Yes
【题意】

就是说给你一组数字,看看它通过栈以后能不能通过某种顺序出栈,使其顺序与下面那一行相同。

      输入:第一行:元素个数

                 第二行:原始顺序

                 之后输入n组目标顺序,当目标顺序输入完成,输入0以结束本次计算。

      输出:可以以目标顺序出栈的话输出Yes,否则No,输出占一行,每组计算之间隔一个空行。

【思路】

      这题完全模拟进出栈过程,思路是这样,先第一个元素进栈,然后检查目标第一个元素是否和栈顶相等,相等的话出栈,否则原始顺序下一个元素进栈,再检查,如此循环。如果能达成目标顺序,最后这个栈一定是空栈,元素肯定都跑出来了,否则就不能达成。

【代码】

#include<cstdio>
#include<stack>
using namespace std;

int main()
{
	int n;
	stack<int > a;
	while(scanf("%d",&n)&&n)
	{
		o1:int b[n+1];
		scanf("%d",&b[1]);
		if(b[1]==0)//看看输入的第一个数是不是0,是的话结束本组输入
		goto o2;		
		else
		{
			while(!a.empty())
			a.pop();//栈清空
			int k=1;
			for(int i=2;i<=n;i++)
			scanf("%d",&b[i]);//输入目标顺序
			for(int i=1;i<=n;i++)
			{
				a.push(i);//首原始元素进栈
				while(!a.empty()&&a.top()==b[k])
				{
					a.pop();
					k++;
				}
			}
			if(k-1==n)//如果出栈元素的数量跟原始元素的元素数量相同,那么说明目标顺序能够达成,此时栈为空,输出yes
			printf("Yes\n");
			else
			printf("No\n");
		}		
		goto o1;//接着输入下一个顺序
		o2:printf("\n");
	}	
}

啊,看懂的话就点个顶吧~
关注一下倒也是极好的呢~

猜你喜欢

转载自blog.csdn.net/silent0001/article/details/52304125