HDU 1054 Strategic Game(无向图的最小点覆盖)

版权声明:未经本人同意,禁止转载。 https://blog.csdn.net/qq_34022601/article/details/86623942

Strategic Game

Problem Description

Bob enjoys playing computer games, especially strategic games, but sometimes he cannot find the solution fast enough and then he is very sad. Now he has the following problem. He must defend a medieval city, the roads of which form a tree. He has to put the minimum number of soldiers on the nodes so that they can observe all the edges. Can you help him?

Your program should find the minimum number of soldiers that Bob has to put for a given tree.

The input file contains several data sets in text format. Each data set represents a tree with the following description:

the number of nodes
the description of each node in the following format
node_identifier:(number_of_roads) node_identifier1 node_identifier2 ... node_identifier
or
node_identifier:(0)

The node identifiers are integer numbers between 0 and n-1, for n nodes (0 < n <= 1500). Every edge appears only once in the input data.

For example for the tree: 

 

the solution is one soldier ( at the node 1).

The output should be printed on the standard output. For each given input data set, print one integer number in a single line that gives the result (the minimum number of soldiers). An example is given in the following table:

Sample Input

4 0:(1) 1

1:(2) 2 3

2:(0)

3:(0)

5 3:(3) 1 4 2

1:(1) 0

2:(0)

0:(0)

4:(0)

Sample Output

1 2

 


数据量较大,采用邻接表存图。

无向图的最大匹配数应该是二分图最大匹配/2;


#include <cstdio>
#include <vector>
/*
343MS	1344K
*/
using namespace std;
int vis[1501];
int match[1501];
struct Node{
	vector <int> adj;
}g[1501];
void Init (int n)
{
	for (int i=0;i<n;i++)
		g[i].adj.clear();
	for (int i=0;i<n;i++)
		match[i]=0,vis[i]=0;
}
bool Find (int u,int n)
{
	for (int i=0;i<g[u].adj.size();i++)
	{
		int v=g[u].adj[i];
		if (!vis[v])
		{	
			vis[v]=1;
			if (match[v]==0 || Find (match[v],n))
			{
				match[v]=u;
				return true;
			}
		}
	}
	return false;
}
int main()
{
	int n,x,y,cnt,ans=0;
	char a,b,c;
	while (~scanf ("%d",&n))
	{
		Init (n);
		ans=0;
		for (int i=0;i<n;i++)
		{
			scanf ("%d:(%d)",&x,&cnt);
			for (int j=0;j<cnt;j++)
			{
				scanf ("%d",&y);
				g[x].adj.push_back(y);
				g[y].adj.push_back(x);
			}
		}
		for (int i=0;i<n;i++)
		{
			if (Find (i,n))
			{
				for (int i=0;i<n;i++)
				{
					vis[i]=0;
				}
				ans++;
			}
		}
		printf ("%d\n",ans/2);
	}
}

猜你喜欢

转载自blog.csdn.net/qq_34022601/article/details/86623942