poj3279(第一天H题)

题目:Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M × N grid (1 ≤ M ≤ 15; 1 ≤ N ≤ 15) of square tiles, each of which is colored black on one side and white on the other side.

As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make.

Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the output when considered as a string. If the task is impossible, print one line with the word “IMPOSSIBLE”.

Input
Line 1: Two space-separated integers: M and N
Lines 2… M+1: Line i+1 describes the colors (left to right) of row i of the grid with N space-separated integers which are 1 for black and 0 for white
Output
Lines 1… M: Each line contains N space-separated integers, each specifying how many times to flip that particular location.
Sample Input
4 4
1 0 0 1
0 1 1 0
0 1 1 0
1 0 0 1
Sample Output
0 0 0 0
1 0 0 1
1 0 0 1
0 0 0 0

解:因为下面一行每次只能影响上一行的一块,要全部翻好则第一行确定时,就已经确定翻多少
只要搜索第一行所有的情况就可以

只有翻与不翻类似二进制0和1,有2的n次方种情况,一直求余二则为求二进制的方法。

代码:

#include<iostream>
using namespace std;
int a[20][20];
int b[20][20];
int c[20][20];
int d[20][20];
int account;
int pint;
int lock;
void remark(int x,int y)
{
	pint = account;
	for (int i = 1; i <= x; i++)
	{
		for (int j = 1; j <= y; j++)
		{
			d[i][j] = c[i][j];
		}
	}
}
void turn(int x, int y)
{
	c[x][y] = 1;
	account++;
	b[x][y] = 1 - b[x][y];
	b[x - 1][y] = 1 - b[x - 1][y];
	b[x + 1][y] = 1 - b[x + 1][y];
	b[x][y - 1] = 1 - b[x][y - 1];
	b[x][y + 1] = 1 - b[x][y + 1];
}
int main()
{
	int m, n;
	while (cin >> m >> n)
	{
		for (int i = 1; i <= m; i++)
		{
			for (int j = 1; j <= n; j++)
			{
				cin >> a[i][j];
			}
		}
		int t = 1 << n;//第一行的情况种类数,向左位运算类似于乘2(计算每种第一行的情况所需次数)
		for (int i = 0; i < t; i++)
		{
			memset(c, 0, sizeof(c));
			for (int i = 1; i <= m; i++)
			{
				for (int j = 1; j <= n; j++)
				{
					b[i][j] = a[i][j];
				}
			}
			int pm = t;
			account = 0;
			pint = 99999;
			for (int i = 1; i <= pm; i++)    //翻转第一行
			{
				if (pm % 2 == 1)
				{
					turn(1, i);
				}
				pm /= 2;
			}
			for (int i = 2; i <= m; i++)
			{
				for (int j = 1; j <= n; j++)
				{
					if (b[i - 1][j] == 1)
					{
						turn(i, j);
					}
				}
			}
			for (int j = 1; j <= n; j++)
			{
				if (b[m][j] == 1)
				{
					break;
				}
				if (j == n)
				{
					lock = 1;  //只要成功一次不会是not impossible
					if (account < pint)
					{
						remark(m, n);
					}
				}
			}
		}
		if (lock == 0)
		{
			cout << "IMPOSSIBLE" << endl;
			return 0;
		}
		for (int i = 1; i <= m; i++)
		{
			for (int j = 1; j <= n; j++)
			{
				if (j != 1)
				{
					cout << " ";
				}
				cout << d[i][j];
				if (j == n)
				{
					cout << endl;
				}
			}
		}
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_44003016/article/details/86800966
今日推荐