You are my brother

版权声明:《本文为博主原创文章,转载请注明出处。 》 https://blog.csdn.net/zbq_tt5/article/details/88900213

                                                                          Time limit       1000 ms

                                                                        Memory limit   131072 kB

Little A gets to know a new friend, Little B, recently. One day, they realize that they are family 500 years ago. Now, Little A wants to know whether Little B is his elder, younger or brother.

Input

There are multiple test cases. 
For each test case, the first line has a single integer, n (n<=1000). The next n lines have two integers a and b (1<=a,b<=2000) each, indicating b is the father of a. One person has exactly one father, of course. Little A is numbered 1 and Little B is numbered 2. 
Proceed to the end of file.

Output

For each test case, if Little B is Little A’s younger, print “You are my younger”. Otherwise, if Little B is Little A’s elder, print “You are my elder”. Otherwise, print “You are my brother”. The output for each test case occupied exactly one line.

Sample Input

5
1 3
2 4
3 5
4 6
5 6
6
1 3
2 4
3 5
4 6
5 7
6 7

Sample Output

You are my elder
You are my brother

题意:

给出一组数据

其中第一个数据的父节点是第二个数据,让求最后1和2之间的关系。

题解:

+因为这道题已经给出ab之间的关系,那么只需进行father[a]=b就行了

    -只需判断1和2距离根节点的长度,就能够知道两者之间的关系!为什么呢?

扫描二维码关注公众号,回复: 5749996 查看本文章

        -因为他们是500年前的家族,所以他们肯定有一个相同的根节点!

#include<stdio.h>
#include<algorithm>
#include<cstring>
#include<cmath>
#include<vector>
#include<map>

using namespace std;
int father[2010];
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        for(int i=0;i<2010;++i)
            father[i]=i;
            int beginn,endd;
        for(int i=0;i<n;++i)
        {
            scanf("%d%d",&beginn,&endd);
            father[beginn]=endd;
        }
        int x1=1,num1=0;
        while(x1!=father[x1])
        {
            x1=father[x1];
            num1++;
        }
        int x2=2,num2=0;
        while(x2!=father[x2])
        {
            x2=father[x2];
            num2++;
        }
        if(num1==num2)
            printf("You are my brother\n");
        else if(num1>num2)
            printf("You are my elder\n");
        else
            printf("You are my younger\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/zbq_tt5/article/details/88900213
my
You