Party All the Time (三分裸题)

In the Dark forest, there is a Fairy kingdom where all the spirits will go together and Celebrate the harvest every year. But there is one thing you may not know that they hate walking so much that they would prefer to stay at home if they need to walk a long way.According to our observation,a spirit weighing W will increase its unhappyness for S 3*W units if it walks a distance of S kilometers.
Now give you every spirit's weight and location,find the best place to celebrate the harvest which make the sum of unhappyness of every spirit the least.

Input

The first line of the input is the number T(T<=20), which is the number of cases followed. The first line of each case consists of one integer N(1<=N<=50000), indicating the number of spirits. Then comes N lines in the order that x [i]<=x [i+1] for all i(1<=i<N). The i-th line contains two real number : X i,W i, representing the location and the weight of the i-th spirit. ( |x i|<=10 6, 0<w i<15 )

Output

For each test case, please output a line which is "Case #X: Y", X means the number of the test case and Y means the minimum sum of unhappyness which is rounded to the nearest integer.

Sample Input

1
4
0.6 5
3.9 10
5.1 7
8.4 10

Sample Output

Case #1: 832

注意左右边界的选取就行了

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<queue>
#include<stack>
#include<set>
#include<map>
#include<vector>
#include<cmath>
const int maxn=1e5+5;
typedef long long ll;
using namespace std;
struct node{
	double x;
	double w;
}p[50005];	
int n,m;
void init(){
	for(int i=0;i<50000;i++){
		p[i].w =0;
		p[i].x =0;
	}
}
double dis(double tmp){
	double sum=0;
	for(int i=0;i<m;i++){
		sum+=abs(p[i].x -tmp)*abs(p[i].x -tmp)*abs(p[i].x -tmp)*p[i].w ;
	}
	return sum;
}
int main(){
	scanf("%d",&n);
	for(int i=1;i<=n;i++){
		init();//初始化 
		scanf("%d",&m);
		for(int j=0;j<m;j++){//输入数据 
			scanf("%lf%lf",&p[j].x ,&p[j].w );
		}
//		double l=p[0].x ;
//		double r=p[m-1].x ;
                double l=-1000005;
                double r=1000005;
		double lm,rm;
		while((r-l)>=0.0000001) {	
		    double tmp = (r-l)/3;//所要求区间的三分之一长度	
			lm = l + tmp;	
			rm = r - tmp;	
			if(dis(lm) <= dis(rm)) {//注意舍弃那个部分
				r = rm;
			} 
			else {		
			    l = lm;	
			}
	    }
	    double num=0;
	    for(int j=0;j<m;j++){
	    	num+=abs(p[j].x -lm)*abs(p[j].x -lm)*abs(p[j].x -lm)*p[j].w ;
		}
		num=num+0.5;
	    printf("Case #%d: %d\n",i,(int)num);
	} 
	return 0;
} 

猜你喜欢

转载自blog.csdn.net/red_red_red/article/details/88924353
ALL