A1073 Scientific Notation/B1024 科学计数法

1073 Scientific Notation (20 分)

Scientific notation is the way that scientists easily handle very large numbers or very small numbers. The notation matches the regular expression [+-][1-9].[0-9]+E[+-][0-9]+ which means that the integer portion has exactly one digit, there is at least one digit in the fractional portion, and the number and its exponent's signs are always provided even when they are positive.

Now given a real number A in scientific notation, you are supposed to print A in the conventional notation while keeping all the significant figures.

Input Specification:

Each input contains one test case. For each case, there is one line containing the real number A in scientific notation. The number is no more than 9999 bytes in length and the exponent's absolute value is no more than 9999.

Output Specification:

For each test case, print in one line the input number A in the conventional notation, with all the significant figures kept, including trailing zeros.

Sample Input 1:

+1.23400E-03

Sample Output 1:

0.00123400

Sample Input 2:

-1.2E+10

Sample Output 2:

-12000000000

1024 科学计数法 (20 分)

科学计数法是科学家用来表示很大或很小的数字的一种方便的方法,其满足正则表达式 [+-][1-9].[0-9]+E[+-][0-9]+,即数字的整数部分只有 1 位,小数部分至少有 1 位,该数字及其指数部分的正负号即使对正数也必定明确给出。

现以科学计数法的格式给出实数 A,请编写程序按普通数字表示法输出 A,并保证所有有效位都被保留。

输入格式:

每个输入包含 1 个测试用例,即一个以科学计数法表示的实数 A。该数字的存储长度不超过 9999 字节,且其指数的绝对值不超过 9999。

输出格式:

对每个测试用例,在一行中按普通数字表示法输出 A,并保证所有有效位都被保留,包括末尾的 0。

输入样例 1:

+1.23400E-03

输出样例 1:

0.00123400

输入样例 2:

-1.2E+10

输出样例 2:

-12000000000
#include <iostream>
#include <string>
#include <cstdio>
using namespace std;

int main()
{
	string str;
	cin >> str;
	int len = str.size();
	if(str[0]=='-') printf("-");
	
	int pos = 0;  //找出E的位置 
	while(str[pos]!='E'){
		pos++;
	}
	
	int exp = 0;  //计算exp的大小 
	for(int i=pos+2; i<len; i++){
		exp = exp*10 + (str[i]-'0');
	}
	if(exp==0){  //指数为0的情况,前面原样输出 
		for(int i=1; i<pos; i++){
			printf("%c",str[i]);
		}
	}
	
	if(str[pos+1]=='-'){  //指数为负 
		printf("0.");
		for(int i=0; i<exp-1; i++){
			printf("0");  //输出指数为负数时,前面要补充的0 
		}
		printf("%c",str[1]);  //输出除了小数点以外的数字
		for(int i=3; i<pos; i++){
			printf("%c",str[i]);
		} 
	}else{  //指数为正 
		for(int i=1; i<pos; i++){  //输出小数点移动之后的数
			if(str[i]=='.') continue;   //略过小数点 
			printf("%c",str[i]);  //输出当前数位 
			if(i==exp+2&&pos-3!=exp){  //小数点加在位置(exp+2)上 
				printf(".");
			}
		}
		for(int i=0; i<exp-(pos-3); i++){  //exp指数过大时,输出多余的0 
			printf("0");
		} 
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/Highlight_Jin/article/details/88752782