PAT甲级--1073 Scientific Notation(20 分)【模拟(科学记数)】

1073 Scientific Notation(20 分)

Scientific notation is the way that scientists easily handle very large numbers or very small numbers. The notation matches the regular expression [+-][1-9].[0-9]+E[+-][0-9]+ which means that the integer portion has exactly one digit, there is at least one digit in the fractional portion, and the number and its exponent's signs are always provided even when they are positive.

Now given a real number A in scientific notation, you are supposed to print A in the conventional notation while keeping all the significant figures.

Input Specification:

Each input contains one test case. For each case, there is one line containing the real number A in scientific notation. The number is no more than 9999 bytes in length and the exponent's absolute value is no more than 9999.

Output Specification:

For each test case, print in one line the input number A in the conventional notation, with all the significant figures kept, including trailing zeros.

Sample Input 1:

+1.23400E-03

Sample Output 1:

0.00123400

Sample Input 2:

-1.2E+10

Sample Output 2:

-12000000000

解题思路:这题我没有把题目看仔细,就想的很复杂,就是上面红色的字,就是整数部分只有一个数字,如果是加号不输出,减号要输出,然后我们得计算出指数部分是有多大,然后再判断指数前面是加还是减,如果是减就只要在前面添加相应数量的0,当然前提是指数>0,要不然原样输出,如果是加号,我们就要判断小数的数量和指数的大小,如果小数的数量多,就要在指数+3的位置后面添加“.”,其他的数据继续输出;如果是<=,那就是将数字全部输出然后再后面相应0的数量。

#include<iostream>
#include<string>
#include<algorithm>
using namespace std;
int main(void)
{
	string s;
	cin>>s;
	int len=s.length();
	if(s[0]=='-') cout<<'-';
	int pos=s.find("E");
	int ex=0;//指数 
	for(int i=pos+2;i<len;i++) ex=(s[i]-'0')+ex*10;
	if(s[pos+1]=='-')
	{
		if(ex>0)
		{
		    cout<<"0.";
			for(int i=1;i<ex;i++) cout<<"0";
			for(int i=1;i<pos;i++)
			{
			    if(isdigit(s[i]))	cout<<s[i];
			}	
		}
		else
		{
			for(int i=1;i<pos;i++)
			cout<<s[i]; 
		}	
	}
	else
	{
		if(ex>=pos-3)
		{
			if(s[1]!=0) cout<<s[1];
			for(int i=3;i<pos;i++)
			{
				 cout<<s[i];
			}
			for(int i=1;i<=(ex-(pos-3));i++) cout<<"0";
		}
		else
		{
			if(s[1]!=0) cout<<s[1];
			for(int i=3;i<(ex+3);i++)
			{
			 	cout << s[i];
			} 
			cout<<".";
			for(int i=ex+3;i<pos;i++)
			{
			 cout << s[i];
			}
		}
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/Imagirl1/article/details/82315898