HDU 1251 字典树

http://acm.hdu.edu.cn/showproblem.php?pid=1251


 

Problem Description

Ignatius最近遇到一个难题,老师交给他很多单词(只有小写字母组成,不会有重复的单词出现),现在老师要他统计出以某个字符串为前缀的单词数量(单词本身也是自己的前缀).

Input

输入数据的第一部分是一张单词表,每行一个单词,单词的长度不超过10,它们代表的是老师交给Ignatius统计的单词,一个空行代表单词表的结束.第二部分是一连串的提问,每行一个提问,每个提问都是一个字符串.

注意:本题只有一组测试数据,处理到文件结束.

Output

对于每个提问,给出以该字符串为前缀的单词的数量.

Sample Input

 

banana band bee absolute acm ba b band abc

Sample Output

 

2 3 1 0

Author

Ignatius.L

思路:字典树模板题,用sum[i]表示以从根结点到i结点的连成的字符串为前缀的单词个数即可。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<vector>
#include<string>
#include<cmath>
#include<map>
#include<algorithm>
#define INF 0x3f3f3f3f
typedef long long ll;
using namespace std;

int tree[400000][26];
int sum[400000];
string s;
int tot;

void Insert()
{
    int root=0;
    int len=s.size();
    for(int i=0;i<len;i++)
    {
        int id=s[i]-'a';
        if(!tree[root][id])
            tree[root][id]=++tot;
        ++sum[tree[root][id]];
        root=tree[root][id];
    }
}

int query()
{
    int root=0;
    int len=s.size();
    for(int i=0;i<len;i++)
    {
        int id=s[i]-'a';
        if(!tree[root][id])
            return 0;
        root=tree[root][id];
    }
    return sum[root];
}

int main()
{
    while(1)
    {
        getline(cin,s);
        if(s.size()==0)
            break;
        Insert();
    }
    while(getline(cin,s))
        printf("%d\n",query());
    return 0;
}

猜你喜欢

转载自blog.csdn.net/xiji333/article/details/88753588