HDU - 1251 (字典树 入门)

Ignatius最近遇到一个难题,老师交给他很多单词(只有小写字母组成,不会有重复的单词出现),现在老师要他统计出以某个字符串为前缀的单词数量(单词本身也是自己的前缀). 

Input

输入数据的第一部分是一张单词表,每行一个单词,单词的长度不超过10,它们代表的是老师交给Ignatius统计的单词,一个空行代表单词表的结束.第二部分是一连串的提问,每行一个提问,每个提问都是一个字符串. 

注意:本题只有一组测试数据,处理到文件结束. 

Output

对于每个提问,给出以该字符串为前缀的单词的数量. 

Sample Input

banana
band
bee
absolute
acm

ba
b
band
abc

Sample Output

2
3
1
0
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int n,m,t;
char s[20];
struct node
{
	int x;
	node *next[30];
};
node *head;
void insert(int len,char *s)
{
	node *p=head;
	for(int i=0;i<len;i++)
	{
		int id=s[i]-'a';
		if(p->next[id]==NULL)
		{
			node *q=new node();
			for(int i=0;i<29;i++) q->next[i]=NULL;
			p->next[id]=q;
		}
		p=p->next[id];
		p->x++;
	}
}
int query(int len,char *s)
{
	node *p=head;
	for(int i=0;i<len;i++)
	{
		int id=s[i]-'a';
		if(p->next[id]!=NULL)
		{
			p=p->next[id];
		}
		else return 0;
	}
	return p->x;
}
int main()
{
	ios::sync_with_stdio(false);
	head=new node();
	for(int i=0;i<29;i++) head->next[i]=NULL;
	while(1)
	{
		gets(s);
		int len=strlen(s);
		if(len==0) break;
		insert(len,s);
	}
	while(cin>>s)
	{
		int len=strlen(s);
		printf("%d\n",query(len,s));
	}
}

猜你喜欢

转载自blog.csdn.net/qq_41286356/article/details/86534654