POJ1417 True Liars(带权并查集+DP)

版权声明:Amove? https://blog.csdn.net/Amovement/article/details/87603920

                                                True Liars

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 6125   Accepted: 2002

Description

After having drifted about in a small boat for a couple of days, Akira Crusoe Maeda was finally cast ashore on a foggy island. Though he was exhausted and despaired, he was still fortunate to remember a legend of the foggy island, which he had heard from patriarchs in his childhood. This must be the island in the legend. In the legend, two tribes have inhabited the island, one is divine and the other is devilish, once members of the divine tribe bless you, your future is bright and promising, and your soul will eventually go to Heaven, in contrast, once members of the devilish tribe curse you, your future is bleak and hopeless, and your soul will eventually fall down to Hell. 

In order to prevent the worst-case scenario, Akira should distinguish the devilish from the divine. But how? They looked exactly alike and he could not distinguish one from the other solely by their appearances. He still had his last hope, however. The members of the divine tribe are truth-tellers, that is, they always tell the truth and those of the devilish tribe are liars, that is, they always tell a lie. 

He asked some of them whether or not some are divine. They knew one another very much and always responded to him "faithfully" according to their individual natures (i.e., they always tell the truth or always a lie). He did not dare to ask any other forms of questions, since the legend says that a devilish member would curse a person forever when he did not like the question. He had another piece of useful informationf the legend tells the populations of both tribes. These numbers in the legend are trustworthy since everyone living on this island is immortal and none have ever been born at least these millennia. 

You are a good computer programmer and so requested to help Akira by writing a program that classifies the inhabitants according to their answers to his inquiries. 

Input

The input consists of multiple data sets, each in the following format : 

n p1 p2 
xl yl a1 
x2 y2 a2 
... 
xi yi ai 
... 
xn yn an 

The first line has three non-negative integers n, p1, and p2. n is the number of questions Akira asked. pl and p2 are the populations of the divine and devilish tribes, respectively, in the legend. Each of the following n lines has two integers xi, yi and one word ai. xi and yi are the identification numbers of inhabitants, each of which is between 1 and p1 + p2, inclusive. ai is either yes, if the inhabitant xi said that the inhabitant yi was a member of the divine tribe, or no, otherwise. Note that xi and yi can be the same number since "are you a member of the divine tribe?" is a valid question. Note also that two lines may have the same x's and y's since Akira was very upset and might have asked the same question to the same one more than once. 

You may assume that n is less than 1000 and that p1 and p2 are less than 300. A line with three zeros, i.e., 0 0 0, represents the end of the input. You can assume that each data set is consistent and no contradictory answers are included. 
 

Output

For each data set, if it includes sufficient information to classify all the inhabitants, print the identification numbers of all the divine ones in ascending order, one in a line. In addition, following the output numbers, print end in a line. Otherwise, i.e., if a given data set does not include sufficient information to identify all the divine members, print no in a line.

Sample Input

2 1 1
1 2 no
2 1 no
3 2 1
1 1 yes
2 2 yes
3 3 yes
2 2 1
1 2 yes
2 3 no
5 4 3
1 2 yes
1 3 no
4 5 yes
5 6 yes
6 7 no
0 0 0

Sample Output

no
no
1
2
end
3
4
5
6
end

Source

Japan 2002 Kanazawa

扫描二维码关注公众号,回复: 5638514 查看本文章

一、原题地址

点我传送

二、大致题意

给出相对关系和各种类人数,让求是否能确定所有人所属的种类。求是否满足唯一的方案。

三、思路

假设说话人的身份可以发现,说no的时候,两个人必然不在一类,说yes的时候必然是一类。

那么首先利用并查集得到多个集合,每个集合内有两个小集合表示同一类的人数,每次必须取一个小集合。

这样就转化为了DP问题,查看最后的方案数是否为1。最后利用DP时记录的人数往回找满足方案的编号。

四、代码

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<cmath>
#include<string>
#include<algorithm>
#include<vector>
#include<queue>
#include<set>
#include<map>
#include<stack>
using namespace std;
const int INF = 0x3f3f3f3f;
#define LL long long int
#define ull unsigned long long
long long  gcd(long long  a, long long  b) { return a == 0 ? b : gcd(b % a, a); }



int n,m,q;
struct Node
{
    int val,fa;
    void init(int i)
    {
        val=0;fa=i;
    }
}peo[10005];

int find(int nx)
{
    if(peo[nx].fa==nx)return nx;
    else
    {
        int Tfa=peo[nx].fa;
        peo[nx].fa=find(peo[nx].fa);
        peo[nx].val=(peo[Tfa].val+peo[nx].val+2)%2;
        return peo[nx].fa;
    }
}

void Union(int x,int y,int d)
{
    int fx=find(x),fy=find(y);
    if(fx!=fy)
    {
        peo[fy].fa=fx;
        peo[fy].val=(peo[x].val+d-peo[y].val+2)%2;
    }
    return ;
}

int a[1005][5];
vector<int>b[1005][5];
int dp[1005][1005];
int pre[1005][1005];
bool vis[1005];
int main()
{
	while(scanf("%d %d %d",&n,&m,&q),n||m||q)
    {
        for(int i=1;i<=m+q;i++)peo[i].init(i);

        int u,v,d;char s[5];
        for(int i=1;i<=n;i++)
        {
            scanf("%d %d %s",&u,&v,s);
            if(s[0]=='y')d=0;
            else d=1;
            Union(u,v,d);
        }
        //read In

        for(int i=0;i<=m+q;i++)
        {
            b[i][0].clear();
            b[i][1].clear();
            a[i][0]=0;
            a[i][1]=0;
            vis[i]=false;
        }
        int tot=0;
        for(int i=1;i<=m+q;i++)
        {
            if(!vis[i])
            {
                ++tot;
                int root=find(i);
                for(int j=i;j<=m+q;j++)
                {
                    if(find(j)==root)
                    {
                        vis[j]=true;
                        b[tot][peo[j].val].push_back(j);
                        a[tot][peo[j].val]++;
                    }
                }
            }
        }
        //处理集合

        memset(dp,0,sizeof(dp));
        dp[0][0]=1;
        for(int i=1;i<=tot;i++)
        {
            for(int j=m;j>=0;j--)
            {
                for(int ty=0;ty<=1;ty++)
                {
                    if(j-a[i][ty]>=0 && dp[i-1][j-a[i][ty]])
                    {
                        dp[i][j]+=dp[i-1][j-a[i][ty]];
                        pre[i][j]=a[i][ty];
                    }
                }
            }
        }
        //DP

        if(dp[tot][m]!=1)printf("no\n");
        else
        {
            vector<int>ans;
            int num=m;
            for(int i=tot;i>=1;i--)
            {
                int now=pre[i][num];
                if(now==a[i][0])
                {
                    for(int j=0;j<a[i][0];j++)
                      ans.push_back(b[i][0][j]);
                }
                else
                {
                    for(int j=0;j<a[i][1];j++)
                      ans.push_back(b[i][1][j]);
                }
                num=num-now;
            }
            sort(ans.begin(),ans.end());
            for(int i=0;i<ans.size();i++)printf("%d\n",ans[i]);
            printf("end\n");
        }

    }
}

猜你喜欢

转载自blog.csdn.net/Amovement/article/details/87603920