True Liars POJ - 1417(并查集+dp)

After having drifted about in a small boat for a couple of days, Akira Crusoe Maeda was finally cast ashore on a foggy island. Though he was exhausted and despaired, he was still fortunate to remember a legend of the foggy island, which he had heard from patriarchs in his childhood. This must be the island in the legend. In the legend, two tribes have inhabited the island, one is divine and the other is devilish, once members of the divine tribe bless you, your future is bright and promising, and your soul will eventually go to Heaven, in contrast, once members of the devilish tribe curse you, your future is bleak and hopeless, and your soul will eventually fall down to Hell.

In order to prevent the worst-case scenario, Akira should distinguish the devilish from the divine. But how? They looked exactly alike and he could not distinguish one from the other solely by their appearances. He still had his last hope, however. The members of the divine tribe are truth-tellers, that is, they always tell the truth and those of the devilish tribe are liars, that is, they always tell a lie.

He asked some of them whether or not some are divine. They knew one another very much and always responded to him “faithfully” according to their individual natures (i.e., they always tell the truth or always a lie). He did not dare to ask any other forms of questions, since the legend says that a devilish member would curse a person forever when he did not like the question. He had another piece of useful informationf the legend tells the populations of both tribes. These numbers in the legend are trustworthy since everyone living on this island is immortal and none have ever been born at least these millennia.

You are a good computer programmer and so requested to help Akira by writing a program that classifies the inhabitants according to their answers to his inquiries.

Input

The input consists of multiple data sets, each in the following format :

n p1 p2
xl yl a1
x2 y2 a2

xi yi ai

xn yn an

The first line has three non-negative integers n, p1, and p2. n is the number of questions Akira asked. pl and p2 are the populations of the divine and devilish tribes, respectively, in the legend. Each of the following n lines has two integers xi, yi and one word ai. xi and yi are the identification numbers of inhabitants, each of which is between 1 and p1 + p2, inclusive. ai is either yes, if the inhabitant xi said that the inhabitant yi was a member of the divine tribe, or no, otherwise. Note that xi and yi can be the same number since “are you a member of the divine tribe?” is a valid question. Note also that two lines may have the same x’s and y’s since Akira was very upset and might have asked the same question to the same one more than once.

You may assume that n is less than 1000 and that p1 and p2 are less than 300. A line with three zeros, i.e., 0 0 0, represents the end of the input. You can assume that each data set is consistent and no contradictory answers are included.

Output

For each data set, if it includes sufficient information to classify all the inhabitants, print the identification numbers of all the divine ones in ascending order, one in a line. In addition, following the output numbers, print end in a line. Otherwise, i.e., if a given data set does not include sufficient information to identify all the divine members, print no in a line.

Sample Input

2 1 1
1 2 no
2 1 no
3 2 1
1 1 yes
2 2 yes
3 3 yes
2 2 1
1 2 yes
2 3 no
5 4 3
1 2 yes
1 3 no
4 5 yes
5 6 yes
6 7 no
0 0 0

Sample Output

no
no
1
2
end
3
4
5
6
end

翻译

传说中,岛上有两个部落,一个是神的,另一个是鬼的,一旦神的部落成员祝福你,你的未来是光明的,有希望的,你的灵魂最终会上天堂,相反,一旦鬼的部落成员诅咒你,你的未来是暗淡的,没有希望的,你的灵魂最终会坠入地狱。

为了防止最坏的情况发生,阿基拉应该区分恶魔和神灵。但是怎么做呢?他们长得一模一样,他不能仅凭外表就把他们区别开来。然而,他还有最后的希望。神圣部落的成员是说真话的,也就是说,他们总是说真话,而恶魔部落的成员是说谎者,也就是说,他们总是说谎。

他问他们中的一些人是否有神灵。他们彼此非常了解,并且总是根据各自的性格“忠实地”回应他(即,他们总是说实话或撒谎)。他不敢问任何其他形式的问题,因为传说一个邪恶的成员如果不喜欢这个问题就会永远诅咒一个人。他还有另外一条关于传说中两个部落人口的有用信息。传说中的这些数字是值得信赖的,因为岛上的每个人都是不朽的,至少在这几千年里没有人出生过。

你是一名优秀的计算机程序员,因此请求你帮助Akira编写一个程序,根据居民对他的询问的回答对他们进行分类。
第一行有三个非负整数n、p1和p2。n是Akira提出的问题数。pl和p2分别是传说中神圣部落和恶魔部落的人口。以下n行每行有三个整数xi yi ai。xi和yi是居民的识别号码,每一个都在1和P1+P2之间,如果居民xi说居民yi是神族的成员(则表示为: xi yi yes),或者不是(则表示 为:xi yi no)。请注意,xi和yi可以是同一个数字,因为“你是神族的成员吗?”是一个有效的问题。另外请注意,两行可能有相同的x和y,因为Akira非常沮丧,可能不止一次地向同一行提出相同的问题。

您可以假设n小于1000,p1和p2小于300。带有三个零(即0)的行表示输入的结束。您可以假设每个数据集都是一致的,不包含相互矛盾的答案。

输出

对于每个数据集,如果它包含足够的信息来分类所有居民,则按升序打印所有神圣居民的识别号,一行一个。此外,在输出数字之后,打印结束一行。否则,即,如果给定的数据集不包含足够的信息来识别所有神圣成员,则在一行中打印no。

代码

#include "stdio.h"
#include "string.h"
#include "algorithm"
#include "map"
using namespace std;
int a[605],fa[605],b[605];//a并查集,fa记录与祖先的关系,b标记;
int dp[605][605],vis[605][5],bbb[605];
int n,sheng,e,k,m;
int find(int x)
{
    
    
	if(a[x]==0) a[x]=x;
	if(x==a[x]) return x;
	int root=find(a[x]);
	fa[x]=(fa[x]+fa[a[x]])%2;
//a[x]是x原来的祖先;
//等号后面fa[x]是x与原来祖先的关系,fa[a[x]]是x的原来祖先与现在祖先的关系,
//有点像三角形的关系(不过这儿是两边之和得第三边的关系),等号前面的fa[x]是x与现在祖先的关系
	a[x]=root;//更新祖先
	return a[x];//也可以写成 return root;
}
int main()
{
    
    
	while(~scanf("%d%d%d",&m,&sheng,&e)&&(m+sheng+e)!=0)
	{
    
    
		n=0;
		char s[5];
		int n1,n2;
		memset(dp,0,sizeof(dp));
		memset(a,0,sizeof(a));
		memset(fa,0,sizeof(fa));
		memset(b,0,sizeof(b));
		memset(bbb,-1,sizeof(bbb));
		memset(vis,0,sizeof(vis));
		while(m--)
		{
    
    
			scanf("%d%d%s",&n1,&n2,s);
			int fn1=find(n1),fn2=find(n2);
			if(fn1==fn2)	continue;
			if(s[0]=='y')
			{
    
    
				a[fn1]=fn2;
				fa[fn1]=fa[n1]+fa[n2];
			}
			else
			{
    
    
				a[fn1]=fn2;
				fa[fn1]=fa[n2]+1+fa[n1];
			}

		}
		for(int i=1; i<=sheng+e; i++)
		{
    
    
			int fi=find(i);
			if(!b[fi])
			 b[fi]=++n;
			 //标记,同时也计算有多少个集合
			vis[b[fi]][fa[i]]++;//祖先为fi的集合中,
			//与fi为同族(fa[i]=0)和与fi为异族(fa[i]=1)分别有多少个
		}
		dp[0][0]=1;
		for(int i=1; i<=n; i++)
		{
    
    
			for(int j=0; j<=sheng; j++)
			{
    
    
				if(vis[i][0]<=j)
					dp[i][j]+=dp[i-1][j-vis[i][0]];
				if(vis[i][1]<=j)
					dp[i][j]+=dp[i-1][j-vis[i][1]];
			}
		}
		if(dp[n][sheng]==1)//有且只有一种
		{
    
    
			int x=n,y=sheng;
			while(x!=0&&y!=0)
			{
    
    
				if(dp[x-1][y-vis[x][0]]==1)
				//要么和祖先(x)同一族,要么是祖先的异族
				{
    
    
					bbb[x]=0;
					y-=vis[x][0];
					x--;
				}
				else
				{
    
    
					bbb[x]=1;
					y-=vis[x][1];
					x--;

				}
			}
			for(int i=1; i<=e+sheng; i++)
			{
    
    
				int zuxian=a[i];
				int biaoji=b[zuxian];
				if(bbb[biaoji]==fa[i])
					printf("%d\n",i);
			}
			printf("end\n");
		}
		else
			printf("no\n");

	}
}

猜你喜欢

转载自blog.csdn.net/weixin_53623850/article/details/120999537