L1-039

L1-039 古风排版 (20 分)
中国的古人写文字,是从右向左竖向排版的。本题就请你编写程序,把一段文字按古风排版。

输入格式:

输入在第一行给出一个正整数N(<100),是每一列的字符数。第二行给出一个长度不超过1000的非空字符串,以回车结束。

输出格式:

按古风格式排版给定的字符串,每列N个字符(除了最后一列可能不足N个)。

输入样例:

4
This is a test case

输出样例:

asa T
st ih
e tsi
 ce s
#include <bits/stdc++.h>

using namespace std;

int main()
{
    int N;
    string str;
    cin >> N;
    cin.get();
    getline(cin, str);
    int str_size = str.size();
    int W = ceil(str_size * 1.0 / N);
    int arr[N][W], index(0);
    for (int j = W - 1; j >= 0; --j)
    {
        for (int i = 0; i < N; ++i)
        {
            if (index < str_size)
                arr[i][j] = index++;
            else
                arr[i][j] = -1;
        }
    }
    for (int i = 0; i < N; ++i)
    {
        for (int j = 0; j < W; ++j)
        {
            if (arr[i][j] != -1)
                cout << str[arr[i][j]];
            else
                cout << ' ';
        }
        if (i + 1 < N)
            cout << endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_43231262/article/details/88696118