Zjnu Stadium(带全并查集模板题)

In 12th Zhejiang College Students Games 2007, there was a new stadium built in Zhejiang Normal University. It was a modern stadium which could hold thousands of people. The audience Seats made a circle. The total number of columns were 300 numbered 1–300, counted clockwise, we assume the number of rows were infinite.
These days, Busoniya want to hold a large-scale theatrical performance in this stadium. There will be N people go there numbered 1–N. Busoniya has Reserved several seats. To make it funny, he makes M requests for these seats: A B X, which means people numbered B must seat clockwise X distance from people numbered A. For example: A is in column 4th and X is 2, then B must in column 6th (6=4+2).
Now your task is to judge weather the request is correct or not. The rule of your judgement is easy: when a new request has conflicts against the foregoing ones then we define it as incorrect, otherwise it is correct. Please find out all the incorrect requests and count them as R.
Input
There are many test cases:
For every case:
The first line has two integer N(1<=N<=50,000), M(0<=M<=100,000),separated by a space.
Then M lines follow, each line has 3 integer A(1<=A<=N), B(1<=B<=N), X(0<=X<300) (A!=B), separated by a space.

Output
For every case:
Output R, represents the number of incorrect request.
Sample Input
10 10
1 2 150
3 4 200
1 5 270
2 6 200
6 5 80
4 7 150
8 9 100
4 8 50
1 7 100
9 2 100
Sample Output
2

Hint
Hint:
(PS: the 5th and 10th requests are incorrect)

理解带权并查集最好用画图,这道题补完仍然一脸懵逼搞不清楚。
用箭头表示根节点方向,箭头向右表示顺时针,一切就清楚了。
头大,带权并查集搞了4天,小伙伴们都轻松搞定了,感觉好菜啊嘤嘤嘤。

#include<iostream>
using namespace std;
int f[100009],rant[100009];int x,y,m;


int find(int x){
	if(x==f[x]) return x;
	int t=f[x];//记录原本的根节点
	f[x]=find(f[x]);//寻找根节点
	rant[x]+=rant[t];更新原本根节点(如果没变就会+0)
	return f[x];返回根节点
}

int uni(int a,int b,int m){
	int fa=find(a);
	int fb=find(b);
	if(fa==fb){
		if(rant[a]+m==rant[b]) return 1;//
		return 0;
	}
	f[fb]=fa;
	rant[fb]=rant[a]+m-rant[b];
	return 1;//不要忘了,如果之前不在同一个集合肯定是正确的。
}


int main(){
	int n1,n2;
	while(~scanf("%d%d",&n1,&n2)){
	for(int i=1;i<=n1;i++){
		f[i]=i;rant[i]=0;
	}
	int ans=0;
	for(int i=0;i<n2;i++){
		scanf("%d%d%d",&x,&y,&m);
		if(!uni(x,y,m)) ans++;
	}
	printf("%d\n",ans);
}
	return 0;
	
}

猜你喜欢

转载自blog.csdn.net/weixin_43806345/article/details/88427099