F - Zjnu Stadium

In 12th Zhejiang College Students Games 2007, there was a new stadium built in Zhejiang Normal University. It was a modern stadium which could hold thousands of people. The audience Seats made a circle. The total number of columns were 300 numbered 1--300, counted clockwise, we assume the number of rows were infinite. 
These days, Busoniya want to hold a large-scale theatrical performance in this stadium. There will be N people go there numbered 1--N. Busoniya has Reserved several seats. To make it funny, he makes M requests for these seats: A B X, which means people numbered B must seat clockwise X distance from people numbered A. For example: A is in column 4th and X is 2, then B must in column 6th (6=4+2). 
Now your task is to judge weather the request is correct or not. The rule of your judgement is easy: when a new request has conflicts against the foregoing ones then we define it as incorrect, otherwise it is correct. Please find out all the incorrect requests and count them as R. 

Input

There are many test cases: 
For every case: 
The first line has two integer N(1<=N<=50,000), M(0<=M<=100,000),separated by a space. 
Then M lines follow, each line has 3 integer A(1<=A<=N), B(1<=B<=N), X(0<=X<300) (A!=B), separated by a space. 
 

Output

For every case: 
Output R, represents the number of incorrect request. 

Sample Input

10 10
1 2 150
3 4 200
1 5 270
2 6 200
6 5 80
4 7 150
8 9 100
4 8 50
1 7 100
9 2 100

Sample Output

2

        
  

Hint

Hint:
(PS: the 5th and 10th requests are incorrect)

题目大意:

有n个人坐在zjnu体育馆里面,然后给出m个他们之间的距离, A B X, 代表B的座位比A多X. 然后求出这m个关系之间有多少个错误,所谓错误就是当前这个关系与之前的有冲突。

#include<iostream>
#include<stdio.h>
using namespace std;
typedef long long ll;
const int M=50000+10;
int pre[M],dis[M];
/*int find(int x){
	int r=x;
	while(pre[r]!=r){
		r=pre[r];
	}
	int t=pre[x];
	dis[x]+=dis[t];
	return r;
}*/
int find(int x){
    if(x==pre[x]) return pre[x];
    int t=pre[x];
    pre[x] = find(pre[x]);
    dis[x] += dis[t];
    return pre[x];
}
int join(int x,int y,int d){
	int fx=find(x),fy=find(y);
	if(fx==fy){
		if(dis[x]+d!=dis[y])//若x,y在一个集合中,判断其距离是否正确 
			return 0;
	    return 1;
	}
	pre[fy]=fx;//fx变成fy的根节点                                                                                                                                                                                                                                                                                                                                                            
	dis[fy]=dis[x]+d-dis[y];//把y所在集合的根节点往后移 
	return 1;               //   fx(dis[x]=2)---x 
}                           //   fy(dis[y]=3)---y
int main()                  //   x(m=5)---------y
{                           //要满足以上条件,则dis[fy]=2+5-3, 
	int n,m;                // 即y的根节点后退这么多
	while(~scanf("%d%d",&n,&m)){
		for(int i=0;i<=n;i++){
			pre[i]=i;
			dis[i]=0;
		}
		int a,b,c,ans=0;
		for(int i=0;i<m;i++){
			scanf("%d%d%d",&a,&b,&c);//cin>>a>>b>>c;
			if(!join(a,b,c)){
				++ans;
			}
		}
		 printf("%d\n",ans);//cout<<ans<<endl;
	}
		
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41555192/article/details/81711444